简介

通过使用 HP Driver Deployment Utility (DDU)，管理员可以为最终用户创建无人值守的驱动程序安装软件包。 此实用程序支持在 Windows 驱动程序存储区中添加打印驱动程序以及在“打印机”文件夹中创建条目。 Driver Deployment Utility 支持设计用于 Microsoft 的添加打印机向导的打印驱动程序。 所有 Microsoft 认证限制和警报均适用。

UI 分为 3 部分：

  1. “软件包源”说明要创建的软件包的类型和驱动程序的位置
  2. “软件包目标”用于标识安装软件包的名称和位置
  3. “创建软件包”启动软件包创建过程


软件包源

驱动程序目录

您可以单击“选择驱动程序…”按钮，通过浏览或键入的方法在驱动程序目录中选择一个 inf 文件。此目录中只能有一个驱动程序软件包，因为本实用程序将把在该目录（包括其子目录）中找到的所有文件打包为可执行文件。 如果下载的是压缩的驱动程序软件包，则在使用本实用程序之前要先将它解压缩。

在某些情况下，目录中可能会存在多个驱动程序 inf 文件（有时会存在一个供彩色打印机使用的 inf 文件和一个供黑白打印机使用的 inf 文件）。 在这种情况下，将出现另一个对话框，让您选择要打包的驱动程序。

目录太大时会出现警告消息。 这是为了防止打包多个驱动程序。 此时，如果目录中包含所需的所有文件，则可以选择继续操作。

一旦选择一个驱动程序目录并找到一个驱动程序，就会显示该目录和驱动程序的信息。

对于支持预配置的驱动程序，将启用以下复选框。 如果选中该复选框，则在按下“创建软件包”按钮之后将显示配置对话框。

安装类型

“预加载驱动程序”是一项供使用直接连接（如通过 USB 电缆）的用户选择的选项。 未来出现即插即用事件时才会安装驱动程序，不过此软件包会把所有的文件打包到 Windows 驱动程序存储区中以供将来使用。 注意： 如果为设备找到了多个驱动程序，操作系统将为“即插即用”事件确定最合适的驱动程序，或弹出驱动程序选择对话框供用户选择。

默认情况下，在运行可执行文件时显示进度对话框。 要关闭进度对话框，请在命令行中使用“/q”运行可执行文件。 如果要提示最终用户在安装完成后连接打印机，请选中“提示用户连接打印机”复选框。

对于使用网络连接的打印机，请选中“创建网络端口并安装驱动程序”选项。 这样将启用“网络设置”按钮，使用该按钮可以进入所需的网络设置。

网络设置

您必须使用下列一种或多种方法来标识网络打印机。 虽然本实用程序并不会与设备进行通信来确定设置是否有效，但是要执行语法检查。 （为能够重新查找设备，请务必指定硬件地址。）

IP 地址：

输入打印机的 IPv4 或 IPv6 地址

硬件地址：

输入打印机的硬件地址

主机名：

输入打印机的主机名

以下是其他一些网络设置。 您可以使用预先输入的默认值，也可以对这些值进行更改。

端口名称：

这是将要创建的网络端口的名称。 如果该名称已经存在，则将在其后添加一个数字以使其唯一。

打印机名称：

这是将在打印机文件夹中出现的打印机名称。 如果该名称已经存在，则将在其后添加一个数字以使其唯一。

将此打印机设置为默认打印机：

“是” - 将此打印机设置为从其他应用程序打印时使用的默认打印机。

“否” - 保留当前的默认打印机设置（除非这是唯一安装的打印机）。

共享此打印机：

“是” - 允许其他用户使用此打印机。

共享名：

此打印机的共享名称。 仅当“共享此打印机”为“是”时才启用此选项。 如果该名称已经存在，则将在其后添加一个数字以使其唯一。


软件包目标

按下“另存为…”按钮，输入要输出的软件包的名称和位置。 本实用程序将在临时目录中创建软件包，然后将软件包移动到最终位置。该软件包包含两个需要同时传送的文件：一个 .exe 文件和一个 .cab文件。

还会将一个包含软件包详细信息的匹配 xml 说明文件复制到最终位置。 xml 软件包仅出于说明目的，DDU 在执行过程中并不使用该软件包。


创建软件包

在输入了以上所有信息之后按下“创建软件包”按钮。 只有在输入了所需信息之后此按钮才可用。一旦按下此按钮，就会启用“取消”按钮和“进度”条。

若要停止创建软件包，请按“取消”按钮。

在运行可执行文件时将显示进度对话框，如果需要，将提示用户直接连接打印机。 如果在执行期间出错，将会显示一个错误对话框。 若不想显示此对话框，请选中“隐藏所有最终用户错误消息”复选框。


其他注意事项：

若要关闭此应用程序，请按右上角的 Windows 关闭按钮。


支持的操作系统

Microsoft Windows 7

Microsoft Windows 7 64 位版本

Microsoft Windows 服务器 2008 R2 64 位版本

Microsoft Windows 8

Microsoft Windows 8 64 位版本

Microsoft Windows 服务器 2012 64 位版本

Microsoft Windows 服务器 2012 R2 64 位版本

Microsoft Windows 8.1

Microsoft Windows 8.1 64 位版本

Microsoft Windows Server 2016 64 位版本

Microsoft Windows 10

Microsoft Windows 10 64 位版本

Microsoft Windows Server 2019 64 位版本<


命令行选项

可通过添加命令行开关来修改最终用户软件包。 可以组合使用命令行开关，但前提是以空格分隔这些开关。 如果命令行包含错误（如无效字符或不正确的格式），则会显示错误消息。 将忽略不正确的命令行开关。 也可以使用“/?”运行最终用户软件包来显示以下命令行说明（英文）。

预加载软件包支持以下命令行选项：

/? 显示命令行信息（仅英文）

/q 隐藏进度栏

/p 提示用户连接打印机

/s 隐藏最终用户错误消息

网络打印机软件包支持以下命令行选项：

/? 显示命令行信息（仅英文）

/q 隐藏进度栏

/s 隐藏最终用户错误消息

/ip <ip 地址> 使用指定的 IP 地址指明打印机，例如，/ip 120.25.5.56

/hw <硬件地址> 使用指定的硬件地址指明打印机，例如，/hw 0001E6299128

/hn <主机名> 使用指定的主机名指明打印机，例如，/hn Myhostname

主机名的长度不能超过 255 个字符，并且只能包含以下字符： A-Z、a-z、0-9 和短划线 (-)。

/pn <端口名> 将指定的名称用作端口名，例如，/pn HPPort

端口名不能包含空格，并且长度不能超过 128 个字符。

/n ”<打印机名>” 将指定的名称用作打印机名，例如，/n "HP LaserJet 8150"

打印机名必须包含在引号内，长度不能超过 40 个字符，并且不能包含任何以下特殊字符： ! # ,

/d 将此打印机设置为默认打印机

/sn ”<共享名>” 启用共享并将指定的名称用作打印机共享名，例如，/sn ”My shared HP LaserJet 8150”

共享名必须包含在引号内，长度不能超过 80 个字符，并且不能包含任何以下特殊字符： / \ : ; “ ? * + = < > [ ]

© Copyright 2019 HP Development Company, L.P.