Вступ

Програма HP Driver Deployment Utility (DDU) надає змогу адміністраторові створити пакет установки драйвера для здійснення автоматичної установки кінцевими користувачами. Ця програма підтримує додавання драйверів принтера до сховища драйверів Windows і створення елементів у папці "Принтери". Driver Deployment Utility підтримує додавання драйверів принтера, призначених для використання з майстром установки принтера Microsoft. Застосовуються всі обов'язкові сповіщення та обмеження програми сертифікації Microsoft.

Інтерфейс користувача розділено на 3 частини:

  1. "Джерело пакета", у якій описано тип пакета, що потрібно створити і де розміщується драйвер
  2. "Призначення пакета", у якій визначаються ім'я та місце розміщення пакета установки
  3. "Створення пакета", у якій запускається процедура створення пакета


Джерело пакета

Каталог драйвера

За допомогою кнопки "Вибрати драйвер…" виберіть inf-файл у каталозі драйвера, для чого знайдіть його або введіть його ім'я. У цьому каталозі має бути лише один пакет драйвера, тому що програма додасть до файла, що виконується, усі файли цього каталогу (і підкаталогів). Якщо завантажено архів пакету драйвера, перед використанням цієї програми його слід розпакувати.

У деяких випадках у каталозі може бути декілька inf-файлів драйвера (іноді один із них призначено для кольорових принтерів, а інший — для чорно-білих). У такому випадку можна у додатковому діалоговому вікні вибрати драйвер для додавання в пакет.

Якщо каталог завеликий, з'явиться попередження. Це допомагає запобігти додаванню в пакет декількох драйверів. Якщо каталог містить усі необхідні файли, ви можете продовжити процес.

Після вибору каталогу та знаходження потрібного драйвера відображається інформація про каталог і драйвер.

Для драйверів, що підтримують попередню конфігурацію, буде активовано прапорець нижче. Якщо встановити цей прапорець, після натискання кнопки "Створити пакет" буде відображено діалогове вікно настроювання.

Тип установки

"Виконати попереднє завантаження драйвера" — цей параметр призначено для користувачів, які використовуватимуть пряме підключення, наприклад, за допомогою кабелю USB. Для установки драйвера буде застосована технологія Plug and Play, проте цей пакет установить усі файли у сховище драйверів Windows для використання в майбутньому. ПРИМІТКА. Якщо для пристрою знайдено декілька драйверів, операційна система визначить, який драйвер найкраще підходить для події Plug and Play, або покаже користувачу діалогове вікно вибору драйвера.

За умовчанням під час виконання файла відображається діалогове вікно. Щоб відключити діалогове вікно, під час запуску програми вкажіть у командному рядку аргумент "/q". Якщо потрібно нагадати користувачеві підключити принтер наприкінці установки, установіть прапорець "Показати запрошення на підключення принтера".

Для принтерів, що використовують мережне підключення, виберіть параметр "Створити мережний порт і встановити драйвер". Кнопку "Параметри мережі" буде активовано. Цю кнопку необхідно натиснути для введення потрібних параметрів мережі.

Параметри мережі

Необхідно ідентифікувати мережний принтер за допомогою одного або кількох зазначених способів. Ця програма не обмінюється даними з пристроєм для перевірки правильності параметрів, але перевіряє синтаксис. (Щоб увімкнути повторне знаходження пристрою, переконайтеся, що вказано його апаратну адресу.)

IP-адреса:

Уведіть адресу IPv4 або IPv6 принтера

Апаратна адреса:

Уведіть апаратну адресу принтера

Ім'я вузла:

Уведіть ім'я вузла принтера

Додатково можна встановити інші параметри мережі. Можна прийняти попередньо введені стандартні значення або змінити будь-які з них.

Ім'я порта:

Це ім'я мережного порта, який буде створено. Якщо ім'я вже існує, до нього буде додано число, щоб зробити ім'я унікальним.

Ім'я принтера:

Це ім'я принтера відображатиметься в папці "Принтери". Якщо ім'я вже існує, до нього буде додано число, щоб зробити ім'я унікальним.

Використовувати як принтер за умовчанням:

Так — принтер використовуватиметься за умовчанням під час друку з інших програм.

Ні — принтер за умовчанням не буде змінено, навіть якщо це єдиний установлений принтер.

Спільно використовувати цей принтер:

Так — інші користувачі зможуть використовувати цей принтер.

Ім'я спільного принтера:

Ім'я для спільного використання принтера. Увімкнуто, лише якщо для параметра "Спільно використовувати цей принтер" вибрано значення Так. Якщо ім'я вже існує, до нього буде додано число, щоб зробити ім'я унікальним.


Призначення пакета

Натисніть кнопку "Зберегти як…", щоб ввести ім'я та вказати місце розміщення вихідного пакета. Програма створить пакет у тимчасовому каталозі, а потім перемістить його до місця кінцевого розміщення. Пакет складатиметься з 2 файлів, які необхідно передавати разом: exe-файл і cab-файл.

Відповідний опис xml-файла з детальними відомостями про пакет також буде скопійовано до місця кінцевого розміщення. Пакет xml є суто інформаційним і не застосовуватиметься DDU під час виконання файла.


Створення пакета

Після введення всієї описаної вище інформації натисніть кнопку "Створити пакет". До цього кнопку не буде активовано. Після натискання цієї кнопки стане активною кнопка "Скасувати" і смуга "Виконання".

Щоб припинити створення пакета, натисніть кнопку "Скасувати".

Файл, що виконується, супроводжуватиметься діалоговим вікном, а в разі необхідності буде відображено запит для користувача щодо прямого підключення принтера. Якщо під час виконання станеться помилка, відобразиться діалогове вікно помилки. Щоб не відображати діалогове вікно помилки, потрібно встановити прапорець "Не відображати всі повідомлення про помилки для кінцевого користувача".


Додаткові примітки

Для закриття цієї програми використовуйте кнопку закривання Windows у правому верхньому куті.


Підтримувані ОС

Microsoft Windows 7

Microsoft Windows 7 (64-розрядний випуск)

Microsoft Windows Server 2008 R2 (64-розрядний випуск)

Microsoft Windows 8

Microsoft Windows 8 (64-розрядний випуск)

Microsoft Windows Server 2012 (64-розрядний випуск)

Microsoft Windows Server 2012 R2 (64-розрядний випуск)

Microsoft Windows 8.1

Microsoft Windows 8.1 (64-розрядний випуск)

Microsoft Windows Server 2016 64-розрядний випуск

Microsoft Windows 10

Microsoft Windows 10 64-розрядний випуск

Microsoft Windows Server 2019 64-розрядний випуск


Параметри командного рядка

Пакет для кінцевих користувачів може бути змінено за допомогою перемикачів командного рядка. Якщо перемикачі командного рядка відокремлено пробілами, їх можна комбінувати. Якщо командний рядок містить помилку (наприклад, неправильний символ або невірне форматування), з'явиться повідомлення про помилку. Перемикачі командного рядка, що містять помилки, не застосовуватимуться. Під час запуску пакету кінцевого користувача після символів "/?" можуть використовуватися інші аргументи командного рядка (англійською).

Пакет попереднього завантаження підтримує такі параметри командного рядка:

/? відобразити відомості про командний рядок (тільки англійською)

/q сховати індикатор виконання

/p запросити підключення до принтера

/s сховати всі повідомлення про помилки (для кінцевого користувача)

Пакет мережного принтера підтримує такі параметри командного рядка:

/? відобразити відомості про командний рядок (тільки англійською)

/q сховати індикатор виконання

/s сховати всі повідомлення про помилки (для кінцевого користувача)

/ip <ip-адреса> використовувати конкретну ІР-адресу для визначення принтера (наприклад, /ip 120.25.5.56)

/hw <апаратна адреса> використовувати конкретну апаратну адресу для визначення принтера (наприклад, /hw 0001E6299128)

/hn <ім'я вузла> використовувати конкретне ім'я вузла для визначення принтера (наприклад, /hn Myhostname)

Ім'я вузла не може перевищувати 255 символів і повинне складатися тільки з таких символів: A-Z, a-z, 0-9 і тире (-).

/pn <ім'я порта> використовувати конкретне ім'я порта (наприклад, /pn HPPort)

Ім'я порта не може містити пробіли, а його довжина не має перевищувати 128 символів.

/n ”<ім'я принтера>” використовувати конкретне ім'я принтера (наприклад, /n "HP LaserJet 8150")

Ім'я принтера не може перевищувати 40 символів, а також містити лапки і такі символи: ! # ,

/d використовувати як принтер за умовчанням

/sn ”<ім'я спільного джерела>” установити спільне джерело та використовувати конкретне ім'я цього джерела для принтера (наприклад, /sn ”My shared HP LaserJet 8150”)

Ім'я спільного джерело не має перевищувати 80 символів, містити лапки і такі символи: / \ : ; “ ? * + = < > [ ]

© Copyright 2019 HP Development Company, L.P.