Giriş

HP Driver Deployment Utility (DDU), yöneticinin son kullanıcılar tarafından tek başına yükleme için sürücü yükleme paketi oluşturmasına olanak sağlar. Bu yardımcı, Windows sürücü deposuna yazıcı sürücüsü ekleme ve Yazıcı klasöründe giriş oluşturma işlemlerini destekler. Driver Deployment Utility, Microsoft’un Yazıcı Ekleme Sihirbazı ile birlikte kullanılmak üzere tasarlanan yazıcı sürücülerini destekler. Tüm Microsoft sertifika kısıtlamaları ve uyarıları geçerlidir.

UI (Kullanıcı Arayüzü) 3 bölüme ayrılmıştır:

  1. ‘Paket Kaynağı’, oluşturmak istediğiniz paket türünü ve sürücü konumunu belirler
  2. ‘Paket Hedefi’, yükleme paketinin adını ve konumunu tanımlar
  3. ‘Paket Oluştur’, paket oluşturma işlemini başlatır


Paket Kaynağı

Sürücü Dizini

‘Sürücü Seç…’ düğmesini kullanarak, sürücü dizinine göz atarak veya sürücü dizinini içine yazarak bir inf dosyası seçin. Bu yardımcı bu dizinde (ve alt dizinlerde) bulunan dosyaların tümünü yürütülebilir dosyaya paketleyeceğinden, bu dizinde yalnızca bir sürücü paketine sahip olmanız gerekir. Sıkıştırılmış bir sürücü paketi yüklediyseniz, bu yardımcıyı kullanmadan önce söz konusu paketi açmanız gerekir.

Bazı durumlarda dizinde birden fazla sürücü inf dosyasına sahip olabilirsiniz (bazen biri renkli, diğeri de siyah beyaz yazıcılar için kullanılır). Bu durumda, ek bir iletişim kutusu paketleyeceğiniz sürücüyü seçmenize olanak tanır.

Ayrıca dizininizin büyük olması durumunda bir uyarı alırsınız. Bu, birden fazla sürücüye paketlemeyi önlemeye yardımcı olmak içindir. İstenen veya gereksinim duyulan dosyaların tümü dizinde bulunuyorsa, bu noktada devam edip etmemeyi tercih edebilirsiniz.

Sürücü dizini seçildikten ve bir sürücü bulunduktan sonra dizin ve sürücü bilgileri görüntülenir.

Önceden yapılandırmayı destekleyen sürücüler için aşağıdaki onay kutusu etkinleştirilir. Bunu seçerseniz, ‘Paket Oluştur’ seçildikten sonra bir yapılandırma iletişim kutusu çalıştırılır.

Yükleme Türü

‘Sürücüyü önyükle’ seçeneği, USB kablosu gibi doğrudan bağlantı kullanan kullanıcıların tercih edebileceği bir seçenektir. Sürücüyü yüklemek için daha sonraki bir Tak ve Çalıştır olayı gerekecektir, ancak tüm dosyalar daha sonra kullanılmak üzere bu paket tarafından Windows sürücü deposuna yüklenecektir. NOT: Bir cihaz için birden fazla sürücü bulunursa İşletim Sistemi, Tak ve Çalıştır olayı için gereken en uygun sürücüyü belirler veya kullanıcıya bir sürücü seçimi iletişim kutusu sağlar.

Yürütülebilir dosya varsayılan olarak ilerleme durumlu bir iletişim kutusuyla çalışır. İlerleme durumlu iletişim kutusunu kapatmak için yürütülebilir dosyayı komut satırından “/q” parametresiyle çalıştırın. Son kullanıcıya yükleme işleminin sonunda yazıcıyı bağlaması için istemde bulunmak isterseniz, ‘Yazıcıyı bağlama isteminde bulun’ onay kutusunu işaretleyin.

Ağ bağlantısı kullanan yazıcılar için ise ‘Ağ bağlantı noktasını oluştur ve sürücüyü yükle’ seçeneğini belirleyin. ‘Ağ Ayarları’ düğmesi etkinleşir; gerekli ağ ayarlarını girmek için bu düğmeyi tıklatmanız gerekir.

Ağ Ayarları

Ağ yazıcısını aşağıdaki yöntemlerden birini veya birkaçını kullanarak tanımlamanız gerekir. Bu yardımcı, ayarların geçerli olup olmadığını belirlemek için cihazla iletişim kurmaz, ancak sözdizimi kontrolü yapar. (Cihazın yeniden bulunmasına olanak tanımak için Donanım Adresi’nin belirtildiğinden emin olun.)

IP Adresi:

Yazıcının IPv4 veya IPv6 adresini girin.

Donanım Adresi:

Yazıcının donanım adresini girin

Ana Bilgisayar Adı:

Yazıcının bağlı olduğu ana bilgisayar adını girin

Aşağıdaki ağ ayarları ek olarak belirtilebilir. Daha önceden girilmiş olan varsayılan değerleri kabul edebilir veya bunlardan istediğinizi değiştirebilirsiniz.

Bağlantı Noktası Adı:

Oluşturulacak olan bağlantı noktası adıdır. Ad zaten varsa, benzersiz yapmak için adın yanına bir rakam eklenir.

Yazıcı Adı:

Yazıcı klasöründe görünecek olan yazıcı adıdır. Ad zaten varsa, benzersiz yapmak için adın yanına bir rakam eklenir.

Bu yazıcıyı varsayılan olarak ayarla:

Evet seçeneği, diğer uygulamalardan yazdırma yapılırken bu yazıcıyı varsayılan olarak belirler.

Hayır seçeneği, yüklü olan tek yazıcının bu olmaması durumunda geçerli yazıcıyı varsayılan olarak bırakır.

Bu yazıcıyı paylaş:

Evet seçeneği, diğerlerinin de bu yazıcıyı kullanmasına olanak tanır.

Paylaşım Adı:

Yazıcının paylaşım adıdır. Yalnızca ‘Bu yazıcıyı paylaş’ seçeneği Evet olarak belirlenirse etkinleştirilir. Ad zaten varsa, benzersiz yapmak için adın yanına bir rakam eklenir.


Paket Hedefi

Çıkış paketi adını ve konumunu girmek üzere ‘Farklı Kaydet…’ düğmesini tıklatın. Yardımcı, paketi temp dizininde oluşturur, ardından son konumuna taşır. Paket, birlikte gönderilmesi gereken 2 dosyadan oluşur: Bir .exe ve bir .cab.

Paket ayrıntılarını içeren uyumlu bir xml açıklama dosyası da son konuma kopyalanır. Xml paketi yalnızca bilgi amaçlıdır, işlem sırasında DDU tarafından kullanılmaz.


Paket Oluştur

Yukarıda bulunan tüm bilgileri girdikten sonra ‘Paket Oluştur’ düğmesini tıklatın. Gerekli tüm bilgiler girilinceye kadar bu düğme devre dışı durumdadır. Seçildiğinde, ‘İptal’ düğmesi ve ‘İlerleme’ çubuğu etkinleştirilir.

Paket oluşturma işlemini durdurmak için ‘İptal’ düğmesini tıklatın.

Yürütülebilir dosya, ilerleme durumlu bir iletişim kutusu ve istenirse doğrudan bağlanan bir yazıcı kullanıcı istemiyle çalışır. Yürütme sırasında bir hatayla karşılaşılırsa, hata iletişim kutusu görüntülenir. Hata iletişim kutusunu kaldırmak için ‘Tüm son kullanıcı hata mesajlarını kaldır’ onay kutusunu işaretlemeniz gerekir.


İlave Bilgiler:

Uygulamayı kapatmak için sağ üstte bulunan Windows kapatma düğmesini kullanın.


Desteklenen İşletim Sistemleri

Microsoft Windows 7

Microsoft Windows 7 64-Bit Edition

Microsoft Windows Server 2008 R2 64-Bit Edition

Microsoft Windows 8

Microsoft Windows 8 64-Bit Edition

Microsoft Windows Server 2012 64-Bit Edition

Microsoft Windows Server 2012 R2 64-Bit Edition

Microsoft Windows 8.1

Microsoft Windows 8.1 64-Bit Edition

Microsoft Windows Server 2016 64 Bit Sürümü

Microsoft Windows 10

Microsoft Windows 10 64 Bit Sürümü

Microsoft Windows Server 2019 64 Bit Sürümü


Komut Satırı Seçenekleri

Son kullanıcı paketi, komut satırı parametreleri eklenerek değiştirilebilir. Komut satırı parametreleri, aralarında boşluk bırakılarak birlikte kullanılabilir. Komut satırında geçersiz karakter veya uygun olmayan biçimlendirme gibi bir hata bulunduğunda, bir hata mesajı görüntülenir. Uygun olmayan komut satırı parametreleri yok sayılır. Komutu izleyen komut satırı açıklaması (İngilizce olarak), son kullanıcı paketinin “/?” ile çalıştırılmasıyla elde edilebilir.

Önceden yüklenen paketler aşağıdaki komut satırı seçeneklerini destekler:

/? komut satırı bilgilerini (Yalnızca İngilizce olarak) görüntüler

/q ilerleme çubuğunu gizler

/p kullanıcıdan yazıcıyı bağlamasını ister

/s son kullanıcı hata mesajlarını gizler

Ağ yazıcısı paketleri aşağıdaki komut satırı seçeneklerini destekler:

/? komut satırı bilgilerini (Yalnızca İngilizce olarak) görüntüler

/q ilerleme çubuğunu gizler

/s son kullanıcı hata mesajlarını gizler

/ip <ip adresi> yazıcıyı tanıtmak için belirtilen IP adresini kullanır, örneğin: /ip 120.25.5.56

/hw <donanım adresi> yazıcıyı tanıtmak için belirtilen Donanım adresini kullanır, örneğin: /hw 0001E6299128

/hn <ana_bilgisayar_adı> yazıcıyı tanıtmak için belirtilen ana bilgisayar adını kullanır, örneğin: /hn Ana_bilgisayarımın_adı

Ana bilgisayar adı 255 karakterden daha uzun olamaz ve yalnızca şu karakterleri bulundurabilir: A-Z, a-z, 0-9 ve tire işareti (-).

/pn <bağlantı_noktası_adı> belirtilen adı, bağlantı noktası adı olarak kullanır, örneğin: /pn HPPort

Bağlantı noktası adı boşluk içeremez ve 128 karakterden uzun olamaz.

/n ”<yazıcı_adı>” belirtilen adı, yazıcı adı olarak kullanır, örneğin: /n "HP LaserJet 8150"

Yazıcı adı tırnak işareti arasında olmalıdır; ad 40 karakterden daha uzun olamaz ve şu özel karakterlerden herhangi birini bulunduramaz: ! # ,

/d bu yazıcıyı varsayılan olarak ayarlar

/sn ”<paylaşım_adı>” paylaşımı açar ve belirtilen adı yazıcı paylaşım adı olarak kullanır, örneğin: /sn ”Paylaşılan HP LaserJet 8150 yazıcım”

Paylaşım adı tırnak işareti arasında olmalıdır; ad 80 karakterden daha uzun olamaz ve şu özel karakterlerden herhangi birini bulunduramaz: / \ : ; “ ? * + = < > [ ]

© Copyright 2019 HP Development Company, L.P.