Uvod

Pripomoček HP Driver Deployment Utility (DDU) omogoča skrbnikom ustvariti namestitveni paket za gonilnike, ki končnim uporabnikom omogoča nespremljano namestitev. Ta pripomoček podpira dodajanje tiskalniških gonilnikov h gonilnikom Windows in ustvarjanje vnosov v mapo tiskalnika. Pripomoček Driver Deployment Utility podpira tiskalniške gonilnike za čarovnika Dodaj tiskalnik sistema Windows. Veljajo vse omejitve in opozorila Microsoftove certifikacije.

Uporabniški vmesnik je razdeljen na 3 dele:

  1. »Vir paketa« opisuje vrsto paketa in mesto gonilnika, ki ga želite ustvariti;
  2. »Cilj paketa« označuje ime in mesto namestitvenega paketa;
  3. »Ustvari paket« zažene postopek izdelave paketa.


Vir paketa

Imenik gonilnika

Z gumbom ‘Izbor gonilnika…’ z brskanjem ali vnosom izberite datoteko .inf v imeniku gonilnika. V tem imeniku imejte samo en paket gonilnikov, ker bo ta pripomoček vse najdene datoteke stisnil v ta imenik (in podimenike) v izvršilne datoteke. Če ste si prenesli stisnjen paket gonilnikov, ga morate pred uporabo programa razširiti.

V nekaterih primerih boste v imeniku imeli več datotek .inf za gonilnike (včasih je ena namenjena za barvne in druga za črno bele tiskalnike). V tem primeru vam bo dodatno pogovorno okno omogočilo izbrati gonilnik, ki ga boste stisnili.

Če je vaš imenik prevelik, se vam prikaže opozorilo. Tako boste preprečili stiskanje več kot enega gonilnika. Če imenik vsebuje vse iskane ali potrebne datoteke, lahko zdaj izberete nadaljevanje.

Ko izberete imenik gonilnika in program najde en gonilnik, se prikažejo podatki o imeniku in gonilniku.

Za gonilnike, ki podpirajo prednastavitve, bo označeno potrditveno okence. Če ga izberete, se bo po pritisku gumba ‘Ustvari paket’ zagnalo konfiguracijsko pogovorno okno.

Vrsta namestitve

‘Predhodno naloži gonilnik’ – je možnost, ki jo lahko izberejo uporabniki, ki bodo uporabljali neposredno povezavo, kot je kabel USB. Za namestitev gonilnika bo sicer potreben dogodek »Plug and Play«, vendar se bodo s tem paketom vse datoteke namestile v skladiščni imenik gonilnikov Windows, kjer bodo na voljo za prihodnjo uporabo. OPOMBA: Če program odkrije več gonilnikov za napravo, operacijski sistem sam določi, kateri je najbolj primeren za dogodek »Plug and Play« ali pa uporabniku prikaže pogovorno okno za izbor gonilnika.

Privzeto se izvršilni programi izvajajo s pogovornim oknom poteka. Če želite zapreti pogovorno okno poteka, izvršilno datoteko zaženite z ukazno vrstico »/q«. Če bi radi končnega uporabnika opozorili, da naj priključi tiskalnik na koncu namestitve, izberite kontrolni okvirček ‘Prikaži opozorilo za priklop tiskalnika’.

Za tiskalnike, ki uporabljajo omrežno povezavo, izberite možnost ‘Ustvari omrežna vrata in namesti gonilnik’. Omogočen bo gumb ‘Omrežne nastavitve’, ki ga kliknite, da vstopite v potrebne omrežne nastavitve.

Omrežne nastavitve

Omrežni tiskalnik morate identificirati z enim ali več spodnjimi postopki. Ta pripomoček se ne poveže z napravo, da bi ugotovil, ali so nastavitve pravilne, ampak preveri skladnjo. (Če želite omogočiti ponovno iskanje naprave, mora biti specificiran naslov strojne opreme.)

Naslov IP:

Vpišite naslov tiskalnika IPv4 ali IPv6.

Naslov strojne opreme:

Vpišite naslov strojne opreme tiskalnika.

Ime gostitelja:

Vpišite ime gostitelja tiskalnika.

Naslednje omrežne nastavitve so dodatne: Sprejmete lahko vnaprej vnesene privzete vrednosti ali pa jih spremenite.

Ime vrat:

To je ime omrežnih vrat, ki se bodo ustvarila. Če ime že obstaja, se bo k imenu dodala še številka, tako da bo ime edinstveno.

Ime tiskalnika:

To je ime tiskalnika, ki se bo prikazalo v mapi tiskalnika. Če ime že obstaja, se bo k imenu dodala še številka, tako da bo ime edinstveno.

Nastavi ta tiskalnik kot privzeti tiskalnik:

Da – tiskalnik se bo nastavil kot privzeti tiskalnik pri tiskanju iz drugih aplikacij.

Ne – trenutna privzeta nastavitev se ohrani, razen če je to edini nameščeni tiskalnik.

Skupna raba tiskalnika:

Da – drugi lahko uporabljajo ta tiskalnik.

Skupno ime:

Skupno ime tiskalnika. Omogočeno samo, če ste pri ‘Skupna raba tiskalnika’ izbrali Da. Če ime že obstaja, se bo k imenu dodala še številka, tako da bo ime edinstveno.


Cilj paketa

Kliknite gumb ‘Shrani kot…’ ter vnesite ime in mesto za izhodni paket. Pripomoček bo ustvaril paket v začasnem imeniku in ga nato prestavil na končno mesto. Paket bo sestavljen iz 2 datotek, ki jih je treba dostaviti skupaj: datotek .exe in .cab.

Na končno mesto se bo skopirala tudi ujemajoča se opisna datoteka .xml s podatki paketa. Paket xml vsebuje le informacije in ga DDU uporablja med izvajanjem.


Ustvari paket

Ko vnesete vse zgoraj navedene podatke, pritisnite gumb ‘Ustvari paket’. Ta gumb bo onemogočen, dokler ne vnesete potrebnih podatkov. Ko ga pritisnete, bosta omogočena gumb ‘Prekliči’ in vrstica ‘Potek’.

Za prekinitev ustvarjanja paketa pritisnite gumb ‘Prekliči’.

Izvršilni program se bo zagnal s pogovornim oknom poteka, razen če ste zahtevali opozorilo za uporabnika pri neposredno priključenem tiskalniku. Če med izvrševanjem pride do napake, se prikaže okno z napako. Če želite izključiti pojav pogovornega okna z napako, odkljukajte kontrolni okvirček ‘Izključi vsa sporočila o napakah za končnega uporabnika’.


Dodatne opombe

Če želite zapreti aplikacijo, uporabite gumb za zaustavitev Windowsov zgoraj desno.


Podprti operacijski sistemi

Microsoft Windows 7

Microsoft Windows 7 (64-bitna izdaja)

Microsoft Windows Server 2008 R2 (64-bitna izdaja)

Microsoft Windows 8

Microsoft Windows 8 (64-bitna izdaja)

Microsoft Windows Server 2012 (64-bitna izdaja)

Microsoft Windows Server 2012 R2 (64-bitna izdaja)

Microsoft Windows 8.1

Microsoft Windows 8.1 (64-bitna izdaja)

Microsoft Windows Server 2016 (64-bitna izdaja)

Microsoft Windows 10

Microsoft Windows 10 (64-bitna izdaja)

Microsoft Windows Server 2019 (64-bitna izdaja)


Možnosti ukazne vrstice

Paket končnega uporabnika lahko spremenite tako, da dodate stikala ukazne vrstice. Stikala ukazne vrstice lahko združujete tako, da jih ločite s presledkom. Če ukazna vrstica vsebuje napako, na primer neveljaven znak ali nepravilno obliko, se prikaže sporočilo o napaki. Neustrezna stikala ukazne vrstice bodo zanemarjena. Spodnji opisi ukazne vrstice so prav tako na voljo (v angleščini), če paket končnega uporabnika zaženete z »/?«.

Paketi prednalaganja podpirajo spodnje možnosti ukazne vrstice:

/? Prikaži informacije ukazne vrstice (samo v angleščini).

/q Ne prikaži vrstice poteka.

/p Pozovi uporabnika, naj priključi tiskalnik.

/s Ne prikaži sporočil o napakah za končnega uporabnika.

Paketi omrežnega tiskalnika podpirajo spodnje možnosti ukazne vrstice:

/? Prikaži informacije ukazne vrstice (samo v angleščini).

/q Ne prikaži vrstice poteka.

/s Ne prikaži sporočil o napakah za končnega uporabnika.

/ip <ip address> Uporabi določeni naslov IP za identifikacijo tiskalnika, npr. /ip 120.25.5.56

/hw <hardware address> Uporabi določeni naslov strojne opreme za identifikacijo tiskalnika, npr. /hw 0001E6299128

/hn <hostname> Uporabi določeno ime gostitelja za identifikacijo tiskalnika, npr. /hn Myhostname

Ime gostitelja ne sme presegati 255 znakov in lahko vsebuje samo naslednje znake:A–Z, a–z, 0–9 in vezaj (-).

/pn <portname> Uporabi določeno ime kot ime vrat, npr. /pn HPPort

Ime vrat ne sme vsebovati presledkov in presegati 128 znakov.

/n ”<printername>” Uporabi določeno ime kot ime tiskalnika, npr. /n "HP LaserJet 8150"

Ime tiskalnika mora biti v narekovajih, ne sme presegati 40 znakov in lahko vsebuje samo naslednje posebne znake:! # ,

/d Nastavi ta tiskalnik kot privzeti tiskalnik.

/sn ”<sharename>” Vklopi skupno rabo in uporabi določeno ime kot ime skupne rabe tiskalnika, npr. /sn ”My shared HP LaserJet 8150”

Ime skupne rabe mora biti v narekovajih, ne sme presegati 80 znakov in lahko vsebuje samo naslednje posebne znake:/ \ : ; “ ? * + = < > [ ]

© Copyright 2019 HP Development Company, L.P.