Úvod

Pomôcka HP Driver Deployment Utility (DDU) umožňuje správcovi systému vytvoriť inštalačný balík ovládača pre koncových používateľov určený na inštaláciu bez nutnosti prítomnosti správcu systému. Táto pomôcka podporuje pridávanie ovládačov tlače do priečinka ovládačov systému Windows a vytváranie položiek v priečinku Tlačiarne. Pomôcka Driver Deployment Utility podporuje ovládače tlače, ktoré sú určené na použitie so Sprievodcom pridaním tlačiarne od spoločnosti Microsoft. Uplatnia sa všetky obmedzenia a výstrahy týkajúce sa certifikátov.

Používateľské rozhranie je rozdelené do troch častí:

  1. Zdroj balíka – opisuje typ balíka a umiestnenie ovládača, ktorý chcete vytvoriť.
  2. Cieľ balíka – predstavuje názov a umiestnenie inštalačného balíka.
  3. Vytvorenie balíka – iniciuje postup vytvárania balíka.


Zdroj balíka

Adresár ovládača

Pomocou tlačidla Vybrať ovládač... vyberte z adresára ovládača súbor INF tak, že ho vyhľadáte alebo priamo zadáte. V tomto adresári by sa mal nachádzať len jeden balík ovládača, pretože pomôcka zahrnie do spustiteľného balíka všetky súbory, ktoré v ňom nájde (vrátane podpriečinkov). Ak ste prevzali skomprimovaný balík ovládača, pred použitím tejto pomôcky ho musíte rozbaliť.

V niektorých prípadoch sa môže v adresári nachádzať niekoľko súborov INF (jeden pre farebné a druhý pre čiernobiele tlačiarne). V takom prípade sa zobrazí ďalšie dialógové okno, v ktorom môžete vybrať ovládač, ktorý chcete zahrnúť do balíka.

Ak je adresár príliš veľký, zobrazí sa upozornenie. Vďaka tomu sa v balíku vždy bude nachádzať len jeden ovládač. Ak v tomto momente adresár obsahuje všetky požadované alebo potrebné súbory, môžete sa rozhodnúť pokračovať.

Po výbere adresára ovládača a vyhľadaní jedného ovládača sa zobrazia informácie o adresári a ovládači.

Pre ovládače, ktoré podporujú konfiguráciu vopred, sa sprístupní políčko nižšie. Jeho výberom a stlačením tlačidla Vytvoriť balík sa otvorí dialógové okno konfigurácie.

Typ inštalácie

Načítanie ovládača vopred – možnosť pre používateľov, ktorí budú využívať priame pripojenie, napríklad prostredníctvom kábla USB. Pri najbližšom použití zariadenia typu Plug and Play bude potrebné ovládač nainštalovať. Balík nainštaluje všetky súbory do priečinka ovládačov systému Windows na ďalšie použitie. POZNÁMKA: Ak sa pre zariadenie nájde viac ovládačov, operačný systém určí, ktorý ovládač najlepšie vyhovuje zariadeniu typu Plug and Play, prípadne zobrazí používateľovi dialógové okno na výber ovládačov.

Spustiteľný súbor sa predvolene spustí s ukazovateľom priebehu. Ak chcete zakázať ukazovateľ priebehu, spustiteľný súbor spustite s parametrom „/q“, ktorý zadáte v príkazovom riadku. Ak chcete po skončení inštalácie upozorniť koncového používateľa na pripojenie tlačiarne, začiarknite políčko Zobraziť upozornenie na pripojenie tlačiarne.

Ak používate tlačiarne so sieťovým pripojením, vyberte možnosť Vytvoriť sieťový port a nainštalovať ovládač. Aktivuje sa tlačidlo Nastavenia siete. Mali by ste naň kliknúť a zadať potrebné nastavenia siete.

Nastavenia siete

Jedným alebo viacerými z uvedených spôsobov musíte identifikovať sieťovú tlačiareň. Táto pomôcka nekomunikuje so zariadením s cieľom zistiť, či sú nastavenia platné. Kontroluje však syntax. (Ak chcete aktivovať opätovné vyhľadanie zariadenia, nezabudnite zadať hardvérovú adresu.)

Adresa IP:

zadajte adresu IPv4 alebo IPv6 tlačiarne.

Hardvérová adresa:

zadajte hardvérovú adresu tlačiarne.

Názov hostiteľa:

zadajte názov hostiteľa tlačiarne.

Nižšie uvedené nastavenia siete sú doplnkové. Môžete prijať alebo zmeniť predvolené hodnoty.

Názov portu:

názov portu siete, ktorý sa vytvorí. Ak už názov existuje, pridá sa k nemu číslo, aby bol názov jedinečný.

Názov tlačiarne:

názov tlačiarne, ktorý sa zobrazí v priečinku Tlačiarne. Ak už názov existuje, pridá sa k nemu číslo, aby bol názov jedinečný.

Nastaviť tlačiareň ako predvolenú:

Áno – táto tlačiareň bude pri tlači z iných aplikácií predvolená.

Nie – aktuálna predvolená tlačiareň sa nezmení (ak nemáte nainštalovanú inú tlačiareň).

Zdieľať tlačiareň:

Áno – túto tlačiareň budú môcť používať aj ďalší používatelia.

Názov zdieľania:

názov zdieľania tlačiarne. Aktívny len vtedy, ak je položka Zdieľať tlačiareň nastavená na možnosť Áno. Ak už názov existuje, pridá sa k nemu číslo, aby bol názov jedinečný.


Cieľ balíka

Ak chcete zadať názov a miesto výstupného balíka, kliknite na tlačidlo Uložiť ako... Pomôcka vytvorí balík v dočasnom adresári a potom ho presunie na cieľové miesto. Balík bude obsahovať dva súbory, ktoré sa musia doručiť spolu: .EXE a .CAB.

Do cieľového adresára sa skopíruje aj príslušný popisný súbor XML s podrobnými informáciami o balíku. Balík súborov XML slúži len na informačné účely a nepoužíva sa počas spúšťania pomôcky DDU.


Vytvorenie balíka

Po zadaní všetkých potrebných informácií kliknite na tlačidlo Vytvoriť balík. Toto tlačidlo nebude aktívne, kým nezadáte všetky potrebné informácie. Po kliknutí na tlačidlo Vytvoriť balík sa aktivujú tlačidlo Zrušiť a panel Priebeh.

Ak chcete zastaviť proces vytvárania balíka, kliknite na tlačidlo Zrušiť.

Spustiteľný súbor sa spustí s dialógovým oknom priebehu a po vyžiadaní aj s výzvou používateľovi na priame pripojenie tlačiarne. Ak sa počas spustenia vyskytne chyba, zobrazí sa dialógové okno s chybovým hlásením. Ak nechcete zobrazovať dialógové okno s chybovým hlásením, začiarknite políčko Zakázať všetky chybové hlásenia pre koncového používateľa.


Ďalšie poznámky

Ak chcete zatvoriť túto aplikáciu, použite tlačidlo systému Windows na zatvorenie, ktoré sa nachádza v pravom hornom rohu.


Podporované OS

Microsoft Windows 7

Microsoft Windows 7 64-bitová edícia

Microsoft Windows Server 2008 R2 64-bitová edícia

Microsoft Windows 8

Microsoft Windows 8 64-bitová edícia

Microsoft Windows Server 2012 64-bitová edícia

Microsoft Windows Server 2012 R2 64-bitová edícia

Microsoft Windows 8.1

Microsoft Windows 8.1 64-bitová edícia

Microsoft Windows Server 2016 (64-bitové vydanie)

Microsoft Windows 10

Microsoft Windows 10 (64-bitové vydanie)

Microsoft Windows Server 2019 (64-bitové vydanie)


Možnosti príkazového riadka

Balík pre koncových používateľov možno upraviť pridaním parametrov príkazového riadka. Parametre príkazového riadka možno vzájomne kombinovať, pokiaľ ich oddeľujú medzery. Ak príkazový riadok obsahuje chybu, napríklad neplatný znak alebo nesprávne formátovanie, zobrazí sa chybové hlásenie. Nesprávne parametre príkazového riadka sa ignorujú. Nasledujúci popis príkazového riadka je k dispozícii (v angličtine) aj po spustení balíka pre koncových používateľov s parametrom „/?“.

Vopred načítavané balíky podporujú nasledujúce možnosti príkazového riadka:

/? zobrazia sa informácie o príkazovom riadku (iba v angličtine),

/q zakáže sa ukazovateľ priebehu,

/p používateľ sa vyzve na pripojenie tlačiarne,

/s zakážu sa chybové hlásenia pre koncového používateľa.

Balíky pre sieťové tlačiarne podporujú nasledujúce možnosti príkazového riadka:

/? zobrazia sa informácie o príkazovom riadku (iba v angličtine),

/q zakáže sa ukazovateľ priebehu,

/s zakážu sa chybové hlásenia pre koncového používateľa,

/ip <adresa ip> pomocou zadanej adresy IP sa identifikuje tlačiareň, napríklad /ip 120.25.5.56,

/hw <hardvérová adresa> pomocou zadanej hardvérovej adresy sa identifikuje tlačiareň, napríklad /hw 0001E6299128,

/hn <názov hostiteľa> pomocou zadaného názvu hostiteľa sa identifikuje tlačiareň, napríklad /hn Môjnázovhostiteľa.

Názov hostiteľa nemôže byť dlhší ako 255 znakov a môže obsahovať iba nasledujúce znaky:A – Z, a – z, 0 – 9 a spojovník (-).

/pn <názov portu> zadaný názov sa použije ako názov portu, napríklad /pn HPPort.

Názov hostiteľa nemôže obsahovať medzery a nemôže byť dlhší ako 128 znakov.

/n "<názov tlačiarne>" zadaný názov sa použije ako názov tlačiarne, napríklad /n "HP LaserJet 8150".

Názov tlačiarne musí byť ohraničený úvodzovkami, nemôže byť dlhší ako 40 znakov a nemôže obsahovať žiadny z týchto špeciálnych znakov: ! # ,

/d nastaví túto tlačiareň ako predvolenú,

/sn "<názov zdieľania>" zapne sa zdieľanie a zadaný názov sa použije ako názov zdieľania tlačiarne, napríklad /sn "Moja zdieľaná HP LaserJet 8150".

Názov zdieľania musí byť ohraničený úvodzovkami, nemôže byť dlhší ako 80 znakov a nemôže obsahovať žiadny z týchto špeciálnych znakov: / \ : ; “ ? * + = < > [ ]

© Copyright 2019 HP Development Company, L.P.