Inleiding

Met de HP Driver Deployment Utility (DDU) kan een beheerder een installatiepakket maken voor installatie van een driver zonder tussenkomst van eindgebruikers. Dit hulpprogramma ondersteunt het toevoegen van printerdrivers aan het driverarchief van Windows en het maken van vermeldingen in de map van de printer. De Driver Deployment Utility ondersteunt printerdrivers die zijn ontworpen voor gebruik met de wizard Printer toevoegen van Microsoft. Alle certificeringsbeperkingen en -waarschuwingen van Microsoft zijn van toepassing.

De gebruikersinterface is onderverdeeld in 3 secties:

  1. In 'Pakketbron' worden het pakkettype en de driverlocatie beschreven die u wilt maken
  2. In 'Pakketdoel' worden de naam en locatie van het installatiepakket aangegeven
  3. In 'Pakket maken' wordt het proces voor het maken van pakketten gestart


Pakketbron

Drivermap

Gebruik de knop 'Driver selecteren…' om een INF-bestand te selecteren in de drivermap door er naartoe te bladeren of door de bestandsnaam in te voeren. Er mag slechts één driverpakket in deze map staan, omdat dit hulpprogramma alle bestanden in deze map (en de submappen) opneemt in het uitvoerbare bestand. Als u een gecomprimeerd driverpakket heeft gedownload, moet u dit decomprimeren voordat u dit hulpprogramma gaat gebruiken.

In sommige gevallen staan er meerdere INF-bestanden voor drivers in de map (soms is er één voor kleurenprinters en één voor monochrome printers). In dat geval kunt u via een extra dialoogvenster selecteren welke driver in het pakket wordt opgenomen.

Ook wordt een waarschuwingsbericht weergegeven als de map groot is. Dit helpt u om te voorkomen dat meer dan één driver in het pakket wordt opgenomen. U kunt er op dit punt voor kiezen om door te gaan als de map alle gewenste of benodigde bestanden bevat.

Nadat de drivermap is geselecteerd en er één driver is gevonden, worden de map en de drivergegevens weergegeven.

Voor drivers die configuratie vooraf ondersteunen, is het onderstaande selectievakje ingeschakeld. Als u dit inschakelt, wordt een configuratievenster weergegeven nadat de knop 'Pakket maken' is geselecteerd.

Installatietype

'Driver vooraf laden': dit is de optie die moet worden geselecteerd voor gebruikers die gebruik zullen maken van een directe verbinding, zoals een USB-kabel. Een toekomstige Plug&Play-gebeurtenis zal zijn vereist om de driver te installeren, maar alle bestanden worden door dit pakket in het driverarchief van Windows geïnstalleerd voor toekomstig gebruik. OPMERKING: Als er meerdere drivers voor een apparaat aanwezig zijn, wordt door het besturingssysteem bepaald welke driver de beste is voor de Plug&Play-gebeurtenis, of krijgt de gebruiker een dialoogvenster te zien waarin de keuze moet worden aangegeven.

Standaard wordt het uitvoerbare bestand uitgevoerd met een voortgangsvenster. Als u het voortgangsvenster wilt sluiten, voert u het uitvoerbare bestand uit met een “/q” in de opdrachtregel. Als u de eindgebruiker wilt vragen om de printer aan te sluiten aan het einde van de installatie, schakelt u het selectievakje 'Prompt tonen om verbinding met de printer te maken' in.

Voor printers waarbij gebruik wordt gemaakt van een netwerkverbinding, selecteert u de optie 'Netwerkpoort maken en driver installeren'. De knop 'Netwerkinstellingen' wordt ingeschakeld. Klik hierop om de vereiste netwerkinstellingen in te voeren.

Netwerkinstellingen

U moet de netwerkprinter identificeren aan de hand van een of meer van de volgende methoden. Dit hulpprogramma communiceert niet met het apparaat om te bepalen of de instellingen geldig zijn, maar voert wel een syntaxiscontrole uit. (Als u het apparaat opnieuw wilt detecteren, moet u een hardwareadres opgeven.)

IP-adres:

Voer het IPv4- of IPv6-adres van de printer in

Hardwareadres:

Voer het hardwareadres van de printer in

Hostnaam:

Voer de hostnaam van de printer in

De volgende netwerkinstellingen zijn extra. U kunt de standaardwaarden die vooraf zijn ingevoerd accepteren of deze waarden wijzigen.

Poortnaam:

Dit is de netwerkpoortnaam die wordt gemaakt. Als de naam reeds bestaat, wordt een nummer toegevoegd om de naam uniek te maken.

Printernaam:

Dit is de printernaam die wordt weergegeven in de map met printers. Als de naam reeds bestaat, wordt een nummer toegevoegd om de naam uniek te maken.

Deze printer instellen als standaardprinter:

Als u Ja kiest, wordt deze printer de standaardprinter bij afdrukken vanuit andere applicaties.

Als u Nee kiest, wordt de huidige standaardoptie gehandhaafd, tenzij deze printer de enige geïnstalleerde printer is.

Deze printer delen:

Als u Ja kiest, kunnen anderen ook gebruikmaken van deze printer.

Share-naam:

Share-naam voor de printer. Alleen ingeschakeld als 'Deze printer delen' is ingesteld op Ja. Als de naam reeds bestaat, wordt een nummer toegevoegd om de naam uniek te maken.


Pakketdoel

Klik op de knop 'Opslaan als' om de naam en locatie voor het uitvoerpakket in te voeren. Het hulpprogramma maakt het pakket in de tijdelijke map en verplaatst het vervolgens naar de uiteindelijke locatie. Het pakket bestaat uit twee bestanden die zich beide op dezelfde locatie moeten bevinden: een EXE-bestand en een CAB-bestand.

Een bijbehorend XML-bestand met de pakketdetails wordt eveneens naar de uiteindelijke locatie gekopieerd. Het XML-pakket dient uitsluitend ter informatie en wordt niet gebruikt door DDU tijdens de uitvoering.


Pakket maken

Klik op de knop 'Pakket maken' als u alle bovenstaande informatie heeft ingevoerd. Deze knop is uitgeschakeld totdat u de vereiste gegevens heeft ingevoerd. Nadat deze knop is geselecteerd, worden de knop 'Annuleren' en de voortgangsbalk actief.

U kunt het maken van het pakket stoppen door op de knop 'Annuleren' te klikken.

Het uitvoerbare bestand wordt uitgevoerd met een voortgangsvenster en, desgevraagd, met een gebruikersprompt voor een printer die direct is aangesloten. Als tijdens de uitvoering een fout optreedt, wordt een dialoogvenster met een foutmelding weergegeven. U kunt het foutvenster onderdrukken door het selectievakje 'Alle foutberichten voor eindgebruikers onderdrukken' in te schakelen.


Aanvullende opmerkingen:

U kunt deze applicatie sluiten door middel van de knop Sluiten van Windows in de rechterbovenhoek van het venster.


Ondersteunde besturingssystemen

Microsoft Windows 7

Microsoft Windows 7 64-Bit Edition

Microsoft Windows Server 2008 R2 64-Bit Edition

Microsoft Windows 8

Microsoft Windows 8 64-Bit Edition

Microsoft Windows Server 2012 64-Bit Edition

Microsoft Windows Server 2012 R2 64-Bit Edition

Microsoft Windows 8.1

Microsoft Windows 8.1 64-Bit Edition

Microsoft Windows Server 2016 64-Bit Edition

Microsoft Windows 10

Microsoft Windows 10 64-Bit Edition

Microsoft Windows Server 2019 64-Bit Edition


Opdrachtregelopties

Het eindgebruikerspakket kan worden gewijzigd door opdrachtregelopties toe te voegen. De opdrachtregelopties kunnen worden gecombineerd wanneer deze van elkaar zijn gescheiden met spaties. Als de opdrachtregel een fout bevat, zoals een ongeldig teken of onjuiste opmaak, verschijnt een foutbericht. Onjuiste opdrachtregelopties worden genegeerd. De volgende opdrachtregelomschrijving is tevens beschikbaar (in het Engels) door het eindgebruikerspakket uit te voeren met een “/?”.

Vooraf geladen pakketten ondersteunen de volgende opdrachtregelopties:

/? opdrachtregelgegevens weergeven (alleen in het Engels)

/q voortgangsbalk onderdrukken

/p gebruiker vragen printer aan te sluiten

/s alle foutberichten voor eindgebruikers onderdrukken

Netwerkprinterpakketten ondersteunen de volgende opdrachtregelopties:

/? opdrachtregelgegevens weergeven (alleen in het Engels)

/q voortgangsbalk onderdrukken

/s alle foutberichten voor eindgebruikers onderdrukken

/ip <ip-adres> het opgegeven IP-adres gebruiken om de printer te herkennen, bijvoorbeeld /ip 120.25.5.56

/hw <hardwareadres> het opgegeven hardwareadres gebruiken om de printer te herkennen, bijvoorbeeld /hw 0001E6299128

/hn <hostnaam> de opgegeven hostnaam gebruiken om de printer te herkennen, bijvoorbeeld /hn Myhostname

De hostnaam mag niet langer zijn dan 255 tekens en mag alleen de volgende tekens bevatten: A-Z, a-z, 0-9 en het streepje (-).

/pn <poortnaam> de opgegeven naam gebruiken als de poortnaam, bijvoorbeeld /pn HPPort

De poortnaam mag geen spaties bevatten en mag niet langer zijn dan 128 tekens.

/n ”<printernaam>” de opgegeven naam gebruiken als de naam van de printer, bijvoorbeeld /n "HP LaserJet 8150"

De printernaam moet tussen aanhalingstekens staan, mag niet langer zijn dan 40 tekens en mag geen van de volgende tekens bevatten: ! # ,

/d deze printer instellen als standaardprinter

/sn ”<sharenaam>” delen inschakelen en de opgegeven naam gebruiken als de sharenaam voor de printer, bijvoorbeeld /sn ”Gedeelde HP LaserJet 8150”

De sharenaam moet tussen aanhalingstekens staan, mag niet langer zijn dan 80 tekens en mag geen van de volgende tekens bevatten: / \ : ; “ ? * + = < > [ ]

© Copyright 2019 HP Development Company, L.P.