소개

HP Driver Deployment Utility(DDU)는관리자가일반사용자의개입없이설치할수있게드라이버설치패키지를작성할수있도록합니다. 이유틸리티는 Windows 드라이버저장에인쇄드라이버를추가하기와프린터폴더에서항목작성하기를지원합니다. Driver Deployment Utility는 Microsoft의프린터추가마법사와함께사용하도록설계된인쇄드라이버를지원합니다. Microsoft 인증제한과경고가모두적용됩니다.

UI는다음세부분으로나뉘어져있습니다.

  1. 패키지소스 - 작성할패키지유형과드라이버위치를설명합니다.
  2. 패키지대상 - 설치패키지의이름과위치를식별합니다.
  3. 패키지작성 - 패키지작성프로세스를시작합니다.


패키지소스

드라이버디렉토리

'드라이버선택' 단추를누르고찾아보거나입력하여드라이버디렉토리에서 inf 파일을선택합니다.이유틸리티는디렉토리(및하위디렉토리)에있는모든파일을실행파일로패키징하므로이디렉토리에는드라이버패키지가하나만있어야합니다. 압축드라이버패키지를다운로드한경우이유틸리티를사용하기전에패키지를확장해야합니다.

일부경우,디렉토리에드라이버 inf 파일이여러개있을수있습니다(예:하나는컬러프린터용, 다른하나는흑백프린터용). 이경우,추가대화상자에서패키징할드라이버를선택할수있습니다.

디렉토리가큰경우에는경고메시지가나타나기도합니다. 이메시지는하나이상의드라이버를패키징하는것을방지하기위한것입니다. 이때, 원하는파일이나필요한파일이디렉토리에모두포함된경우,계속하도록선택할수있습니다.

드라이버디렉토리를선택하고드라이버를하나찾으면디렉토리및드라이버정보가표시됩니다.

사전구성을지원하는드라이버의경우아래확인란이활성화됩니다. '패키지작성'단추를선택한후이확인란을선택하면구성대화상자가실행됩니다.

설치유형

드라이버사전로드- USB 케이블과같은직접연결을사용하는사용자를위한옵션입니다. 드라이버를설치하려면이후플러그앤플레이이벤트가필요하지만, 이패키지는이후에사용하도록Windows 드라이버저장에모든파일을설치합니다. 주: 여러개의드라이버가발견된경우, 운영체제는어떤드라이버가플러그앤플레이이벤트에가장잘맞는지를결정하거나사용자에게드라이버선택대화상자를제시합니다.

기본적으로실행파일은진행대화상자와함께실행됩니다. 진행대화상자를끄려면명령줄에서“/q”를지정하여실행파일을실행합니다. 설치가끝날때프린터를연결하라는메시지를일반사용자에게표시하려면 프린터연결을위한프롬프트표시 확인란을선택합니다.

네트워크연결을사용하는프린터의경우 네트워크포트작성및드라이버설치 옵션을선택합니다. 네트워크설정 단추가활성화되며, 이단추를눌러필수네트워크설정을입력해야합니다.

네트워크설정

다음중하나이상의방법을사용하여네트워크프린터를식별해야합니다. 이유틸리티는설정이유효한지확인하기위해장치와통신하지는않지만구문확인을수행합니다. (장치를다시검색하려면하드웨어주소가지정되었는지확인합니다.)

IP 주소:

프린터의IPv4 또는 IPv6 주소를입력합니다.

하드웨어주소:

프린터의하드웨어주소를입력합니다.

호스트이름:

프린터의호스트이름을입력합니다.

다음은추가네트워크설정입니다. 미리입력된기본값을승인하거나변경할수있습니다.

포트이름:

작성될네트워크포트이름입니다. 이름이이미존재할경우고유한이름으로만들기위해번호가추가됩니다.

프린터이름:

프린터폴더에나타날프린터이름입니다. 이름이이미존재할경우고유한이름으로만들기위해번호가추가됩니다.

이프린터를기본값으로설정:

예- 다른응용프로그램에서인쇄할때이프린터를기본값으로합니다.

아니오 - 이프린터가유일하게설치된프린터가아닌경우현재프린터를기본값으로유지합니다.

이프린터공유:

예 - 다른사용자가이프린터를사용할수있습니다.

공유이름:

프린터의공유이름입니다. '이프린터공유'가 예 인경우에만사용됩니다. 이름이이미존재할경우고유한이름으로만들기위해번호가추가됩니다.


패키지대상

'다른이름으로저장'단추를선택하여출력패키지의이름과위치를입력합니다. 유틸리티는패키지를임시디렉토리에작성한후최종위치로이동합니다. 패키지는함께전달해야하는 2개의파일, .exe 파일과.cab 파일로구성됩니다.

패키지세부정보가포함된일치하는xml 설명파일도최종위치로복사됩니다. xml 패키지는정보만제공하며실행중에DDU에의해사용되지않습니다.


패키지작성

위의정보를모두입력한후패키지작성단추를선택합니다. 필수정보를모두입력할때까지이단추는비활성화됩니다. 이단추를선택하면 '취소'단추와 '진행'표시줄이활성화됩니다.

패키지작성을중지하려면취소단추를선택합니다.

진행대화상자와함께실행파일이실행되며요청한경우직접연결프린터에대한사용자프롬프트도표시됩니다. 실행중에오류가발생하면오류대화상자가나타납니다. 오류대화상자를표시하지않으려면모든일반사용자오류메시지표시안함확인란을선택해야합니다.


추가정보:

이응용프로그램을닫으려면오른쪽위의 Windows 닫기단추를사용합니다.


지원되는 OS

Microsoft Windows 7

Microsoft Windows 7 64비트 Edition

Microsoft Windows Server 2008 R2 64비트 Edition

Microsoft Windows 8

Microsoft Windows 8 64비트 Edition

Microsoft Windows Server 2012 64비트 Edition

Microsoft Windows Server 2012 R2 64비트 Edition

Microsoft Windows 8.1

Microsoft Windows 8.1 64비트 Edition

Microsoft Windows Server 2016 64비트 Edition

Microsoft Windows 10

Microsoft Windows 10 64비트 Edition

Microsoft Windows Server 2019 64비트 Edition


명령줄옵션

명령줄스위치를추가하여일반사용자패키지를수정할수있습니다. 공백으로분리된경우명령줄스위치를결합할수있습니다. 잘못된문자또는부적절한서식화와같은오류가명령줄에포함된경우오류메시지가표시됩니다. 부적절한명령줄스위치는무시됩니다. 일반사용자패키지를“/?”와함께실행하여다음과같이명령줄에대한설명(영어로)도참고할수있습니다.

사전로드패키지는다음명령줄옵션을지원합니다.

/? 명령줄정보를표시합니다(영어만지원).

/q 진행표시줄을표시하지않습니다.

/p 프린터를연결하라는메시지를사용자에게표시합니다.

/s 일반사용자오류메시지를표시하지않습니다.

네트워크프린터패키지는다음명령줄옵션을지원합니다.

/? 명령줄정보를표시합니다(영어만지원).

/q 진행표시줄을표시하지않습니다.

/s 일반사용자오류메시지를표시하지않습니다.

/ip <ip 주소> 지정된 IP 주소를사용하여프린터를식별합니다(예: /ip 120.25.5.56).

/hw <하드웨어주소> 지정된하드웨어주소를사용하여프린터를식별합니다(예: /hw 0001E6299128).

/hn <호스트이름> 지정된호스트이름을사용하여프린터를식별합니다(예: /hn Myhostname).

호스트이름은 255자를초과할수없으며 A-Z, a-z, 0-9, 대시(-) 등의문자만포함할수있습니다.

/pn <포트이름> 지정한이름을포트이름으로사용합니다(예: /pn HPPort).

포트이름은공백을포함할수없으며 128자를초과할수없습니다.

/n ”<프린터이름>” 지정한이름을프린터이름으로사용합니다(예: /n "HP LaserJet 8150").

프린터이름은따옴표로묶어야하고 40자를초과할수없으며 !, #과같은특수문자를포함할수없습니다.

/d 이프린터를기본값으로설정합니다.

/sn”<공유이름>” 공유를켜고지정한이름을프린터의공유이름으로사용합니다(예: /sn ”My shared HP LaserJet 8150”).

공유이름은따옴표로묶어야하고 80자를초과할수없으며 / \ : ; “ ? * + = < > [ ] 등의특수문자를포함할수없습니다.

© Copyright 2019 HP Development Company, L.P.