Uvod

Program HP Driver Deployment Utility (DDU) omogućava administratoru stvaranje paketa za instalaciju upravljačkog programa za automatsku instalaciju za krajnje korisnike. Ovaj uslužni program podržava dodavanje upravljačkih programa pisača u spremište upravljačkih programa u OS Windows i stvaranje unosa u mapi pisača. Driver Deployment Utility podržava upravljačke programe pisača namijenjene za korištenje s Microsoftovim čarobnjakom za dodavanje pisača. Primjenjuju se sva ograničenja i upozorenja za certifikate tvrtke Microsoft.

Korisničko je sučelje podijeljeno u 3 dijela:

  1. "Izvor paketa" opisuje vrstu paketa i lokaciju upravljačkog programa koji želite stvoriti
  2. "Odredište paketa" označava naziv i lokaciju instalacijskog paketa
  3. "Stvaranje paketa" pokreće postupak stvaranja paketa


Izvor paketa

Mapa upravljačkog programa

Pomoću gumba "Odaberi pisač…" odaberite inf datoteku u mapi upravljačkih programa pretraživanjem naziva ili upisivanjem. U ovoj mapi smijete imati samo jedan paket s upravljačkim programom jer će ovaj uslužni program spakirati sve datoteke iz mape (i podmapa) u izvršnu datoteku. Ako ste preuzeli komprimirani paket s upravljačkim programom, morate ga otpakirati prije korištenja ovoga uslužnog programa.

U nekim slučajevima mogli biste imati višestruke inf datoteke za upravljačke programe u mapi (ponekad je jedan za pisače u boji, a drugi za crno-bijele). U tom će se slučaju pojaviti dodatni dijaloški okvir u kojemu ćete odabrati upravljački program za pakiranje.

Ako je mapa velika, bit ćete na to upozoreni. Ovo sprječava mogućnost pakiranja više od jednoga upravljačkog programa. Možete se odlučiti nastaviti ako mapa sadrži sve željene ili potrebne datoteke.

Nakon odabira mape i pronalaska jednog upravljačkog programa, prikazat će se podaci o mapi i upravljačkom programu.

Za upravljačke programe koji podržavaju gotovu konfiguraciju bit će omogućen donji potvrdni okvir. Njegovim odabirom pokrenut će se konfiguracijski dijalog nakon odabira gumba "Stvaranje paketa".

Vrsta instalacije

"Učitavanje upravljačkog programa" - je mogućnost koju trebaju odabrati korisnici koji koriste izravnu vezu, kao što je USB kabel. Budući događaj Plug and Play (Uključi i radi) bit će nužan za instalaciju upravljačkog programa, ali će se sve datoteke instalirati u pohranu upravljačkih programa u OS Windows za buduću uporabu ovog paketa. NAPOMENA: Ako se za uređaj pronađe nekoliko upravljačkih programa, operacijski sustav odredit će koji upravljački program najbolje odgovara događaju Plug and Play (Uključi i radi) ili prikazati korisniku dijalog za odabir upravljačkog programa.

Izvršna se datoteka u pravilu pokreće s dijaloškim okvirom napretka. Da biste isključili dijaloški okvir napretka, pokrenite izvršnu datoteku unosom "/q" u naredbenom retku. Ako želite da se od korisnika zatraži povezivanje pisača na kraju instalacije, odaberite potvrdni okvir "Prikaži poruku za spajanje pisača".

Za pisače koji koriste mrežnu vezu, odaberite mogućnost "Stvori mrežni ulaz i instaliraj upravljački program". Gumb "Mrežne postavke" bit će omogućen i morate ga pritisnuti kako biste unijeli tražene mrežne postavke.

Mrežne postavke

Mrežni pisač morate prepoznati pomoću jedne ili više sljedećih metoda. Ovaj uslužni program ne komunicira s uređajem kako bi potvrdio valjanost postavki, već provjerava sintaksu. (Kako biste omogućili ponovno otkrivanje uređaja, provjerite je li navedena Hardverska adresa).

IP adresa:

Unesite IPv4 ili IPv6 adresu pisača

Hardverska adresa:

Unesite hardversku adresu pisača

Naziv glavnog računala:

Unesite naziv glavnog računala pisača

Sljedeće mrežne postavke su dodatne. Možete prihvatiti unaprijed zadane vrijednosti ili ih promijeniti.

Naziv ulaza:

Ovo je naziv mrežnog ulaza koji će biti stvoren. Ako naziv već postoji, dodat će mu se broj kako bi bio jedinstven.

Naziv pisača:

Ovo je naziv pisača koji će se pojaviti u mapi pisača. Ako naziv već postoji, dodat će mu se broj kako bi bio jedinstven.

Postavi ovaj pisač kao zadani:

Da – učinit će pisač zadanim prilikom ispisa iz drugih programa.

Ne – zadržat će trenutni zadani pisač, osim ako ovo nije jedini instalirani pisač.

Dijeljenje ovog pisača:

Da – dopustit će drugima korištenje ovog pisača.

Zajednički naziv:

Zajednički naziv pisača. Omogućeno samo ako je odabrano Da pod "Dijeljenje ovog pisača". Ako naziv već postoji, dodat će mu se broj kako bi bio jedinstven.


Odredište paketa

Odaberite gumb "Spremi kao..." kako biste unijeli naziv i lokaciju izlaznog paketa. Ovaj će uslužni program stvoriti paket u privremenoj mapi i potom ga premjestiti na konačnu lokaciju. Paket će se sastojati od 2 datoteke koje treba isporučiti zajedno: .exe i .cab.

Na konačnu lokaciju će biti kopirana i odgovarajuća xml datoteka opisa s pojedinostima o paketu. Xml paket je samo informativan i program DDU ga ne koristi tijekom izvršavanja.


Stvaranje paketa

Odaberite gumb "Stvaranje paketa" nakon što unesete sve gore navedene podatke. Ovaj će gumb biti onemogućen ako niste unijeli sve tražene podatke. Kad ga odaberete, aktivirat će se gumb "Odustani" i traka "Odvijanje".

Za zaustavljanje stvaranja paketa odaberite gumb "Odustani".

Izvršna datoteka pokrenut će se s dijaloškim okvirom napretka i, ako se to zatraži, korisničkim upitom za izravno spajanje pisača. Ako tijekom izvršenja dođe do pogreške, pojavit će se dijaloški okvir o pogrešci. Za izostavljanje dijaloga o pogrešci morate odabrati potvrdni okvir "Izostavi sve poruke o pogrešci krajnjem korisniku".


Dodatne napomene:

Za zatvaranje ovog programa koristite gumb za zatvaranje OS Windows u gornjem desnom kutu.


Podržani operacijski sustavi

Microsoft Windows 7

64-bitno izdanje sustava Microsoft Windows 7

64-bitno izdanje sustava Microsoft Windows Server 2008 R2

Microsoft Windows 8

64-bitno izdanje sustava Microsoft Windows 8

64-bitno izdanje sustava Microsoft Windows Server 2012

64-bitno izdanje sustava Microsoft Windows Server 2012 R2

Microsoft Windows 8.1

64-bitno izdanje sustava Microsoft Windows 8.1

64-bitno izdanje sustava Microsoft Windows Server 2016

Microsoft Windows 10

64-bitno izdanje sustava Microsoft Windows 10

64-bitno izdanje sustava Microsoft Windows Server 2019


Mogućnosti naredbenog retka

Paket krajnjeg korisnika moguće je izmijeniti dodavanjem prekidača naredbenog retka. Prekidače naredbenog retka moguće je kombinirati ako su odvajaju razmacima. Poruka o pogrešci prikazuje se ako naredbeni redak sadrži pogrešku, poput nevažećeg znaka ili pogrešnog oblikovanja. Nepravilni prekidači naredbenog retka se ignoriraju. Dostupan je i sljedeći opis naredbenog retka (na engleskom) pokretanjem paketa krajnjeg korisnika pomoću naredbe "/?".

Unaprijed učitani paketi podržavaju sljedeće mogućnosti naredbenog retka:

/? prikaz informacija naredbenog retka (samo na engleskom)

/q izostavljanje trake napretka

/p upit korisniku za spajanje pisača

/s izostavljanje poruka o pogreškama krajnjem korisniku

Paketi mrežnog pisača podržavaju sljedeće mogućnosti naredbenog retka:

/? prikaz informacija naredbenog retka (samo na engleskom)

/q izostavljanje trake napretka

/s izostavljanje poruka o pogreškama krajnjem korisniku

/ip <ip adresa> koristi navedenu IP adresu za prepoznavanje pisača, na primjer /ip 120.25.5.56

/hw <hardverska adresa> koristi navedenu Hardversku adresu za prepoznavanje pisača, na primjer /hw 0001E6299128

/hn <naziv glavnog računala> koristi navedeni naziv glavnog računala za prepoznavanje pisača, na primjer /hn Myhostname

Naziv glavnog računala ne smije imati više od 255 znakova i može sadržavati samo sljedeće znakove: A-Z, a-z, 0-9 i crticu (-).

/pn <naziv ulaza> koristi navedeni naziv kao naziv ulaza, na primjer /pnHPPort

Naziv ulaza ne smije sadržavati razmake niti imati više od 128 znakova:

/n "<naziv pisača>" koristi navedeni naziv kao naziv pisača, na primjer /n "HP LaserJet 8150"

Naziv pisača mora se nalaziti u navodnicima, ne smije imati više od 40 znakova i ne može sadržavati nijedan od ovih posebnih znakova: ! # ,

/d postavlja ovaj pisač kao zadani

/sn "<zajednički naziv>" uključuje dijeljenje i koristi navedeni naziv kao zajednički naziv pisača, na primjer /sn "My shared HP LaserJet 8150"

Zajednički naziv mora se nalaziti u navodnicima, ne smije imati više od 80 znakova i ne može sadržavati nijedan od ovih posebnih znakova: / \ : ; “ ? * + = < > [ ]

© Copyright 2019 HP Development Company, L.P.