Sissejuhatus

HP Driver Deployment Utility (DDU) võimaldab administraatoril luua draiveri installeerimispaketi lõppkasutajale vaikseks, järelevalveta installeerimiseks.Utiliit toetab prindidraiverite lisamist Windowsi draiverisalve ja kirjete loomist printeri kaustas.Driver Deployment Utility toetab prindidraiverite lisamist, mis on mõeldud kasutamiseks Microsoft’i printeri lisamise viisardiga (Add Printer Wizard).Kehtivad kõik Microsoft’i sertifikaadi piirangud ja hoiatused.

Kasutajaliides on jagatud kolme ossa.

  1. „Paketi allikas“ kirjeldab paketi tüüpi ja draiveri asukohta, mida te luua soovite;
  2. „Paketi siht“ määratleb installeerimispaketi nime ja asukoha;
  3. „Loo pakett“ käivitab paketi loomise protsessi.


Paketi allikas

Draiverikataloog

Valige inf-fail nupuga „Vali draiver...“ draiveri kataloogi sirvides või trükkige faili nimi. Kataloogis tohib olla ainult üks draiveripakett, kuna see utiliit tihendab kõik kataloogis (ja alamkataloogides) olevad failid täitmisfaili. Kui olete alla laadinud tihendatud draiveripaketi, peate selle enne utiliidi kasutamist lahti pakkima.

Mõnel juhul võib kataloogis olla mitu draiveri inf-faili (vahel on üks värvi- ja teine ühevärviliste printerite jaoks). Sellisel juhul kuvatakse lisadialoog, mis võimaldab valida, millist draiveripaketti valida.

Samuti hoiatatakse liiga suure kataloogi puhul. Selle eesmärk on aidata ära hoida rohkem kui ühe draiveri tihendamist. Võite valida jätkamise, kui kataloog sisaldab kõiki soovitud või vajalikke faile.

Kui draiveri kataloog on valitud ja üks draiver leitud, kuvatakse kataloog ja draiveri informatsioon.

Eelkonfiguratsiooni toetavate draiverite korral on alltoodud märkeruut aktiveeritud. Selle valimisel käivitatakse pärast nupu „Loo pakett“ klõpsamist konfiguratsioonidialoog.

Installeerimise tüüp

Suvandit „Eellaadige draiver“ saavad valida kasutajad, kes kasutavad otseühendust, näiteks USB-kaablit. Draiveri installeerimiseks võib olla vajalik hilisem isehäälestustoiming (Plug and Play), kuid pakett talletab kõik failid edaspidiseks kasutamiseks Windowsi draiveri mällu. TÄHELEPANU! Kui seadmele leitakse mitu draiverit, määrab operatsioonisüsteem, milline neist on isehäälestustoiminguks (Plug and Play) kõige sobivam või kuvab kasutajale draiveri valiku dialoogi.

Kõik täitefailid käivituvad toimingute dialoogiakna kaudu vaikimisi. Toimingute dialoogiakna väljalülitamiseks käivitage täitefailid käsureal käsuga „/q“. Kui soovite, et lõppkasutaja saaks installeerimise lõppedes viipe printeri ühendamiseks, siis valige märkeruut „Kuva printeri ühendamise viip“.

Valige võrguühendust kasutavate printerite jaoks suvand „Loo võrguport ja installeeri draiver“. Nõutavate võrgusätete sisestamiseks klõpsake aktiveerunud nuppu „Võrgusätted“.

Võrgusätted

Kasutage võrguprinteri tuvastamiseks ühte või mitut alljärgnevat meetodit. Utiliit ei võta sätete kehtivuse kontrollimiseks seadmega ühendust, kuid kontrollib süntaksit. (Seadme uuesti leidmiseks kontrollige, kas riistvara aadress on täpsustatud.)

IP-aadress:

sisestage printeri IPv4- või IPv6-aadress.

Riistvara-aadress

sisestage printeri riistvara-aadress.

Hostinimi:

sisestage printeri hostinimi.

Järgnevad võrgusätted on lisaks.Võite kinnitada eelnevalt sisestatud vaikeväärtused või muuta neist ükskõik millist.

Pordinimi:

see on loodava võrgupordi nimi.Kui selline nimi juba eksisteerib, lisatakse nimele number, et muuta see unikaalseks.

Printeri nimi:

see on printeri nimi, mis kuvatakse printerite kaustas.Kui selline nimi juba eksisteerib, lisatakse nimele number, et muuta see unikaalseks.

Määra printer vaikeprinteriks:

Jah – määrab printeri muudest rakendustest printimisel vaikeprinteriks.

Ei: ei muuda printeri vaikeolekut, v.a juhul, kui see ongi ainus installeeritud printer.

Jaga printerit:

Jah: lubab teistel seda printerit kasutada.

Jaga nime:

jaga printeri nime.Aktiveeritud ainult juhul, kui valiku „Jagada printerit“ väärtus on Jah.Kui selline nimi juba eksisteerib, lisatakse nimele number, et muuta see unikaalseks.


Paketi sihtkoht

Valige väljundpaketi nime ja asukoha sisestamiseks nupp „Salvesta nimega...“.Utiliit loob paketi ajutises kataloogis ning tõstab seejärel lõplikku asukohta.Paketis on kaks faili, mis tuleb edastada koos:exe-fail ja cab-fail

Lõppasukohta kopeeritakse ka vastav paketi üksikasjade kirjeldusega xml-fail.Xml-pakett on üksnes informatiivne, seda ei kasutata DDU poolt käivitamise ajal.


Loo pakett

Kui olete sisestanud kogu ülaltoodud info, klõpsake nuppu „Loo pakett“.See nupp ei aktiveeru enne, kui olete sisestanud nõutava informatsiooni.Nupu klõpsamisel aktiveerub nupp „Tühista“ ja riba „Edenemine“.

Valige paketi loomise katkestamiseks nupp „Tühista“.

Täitefail töötab toimingute dialoogiakna kaudu ja vajadusel ka printeri otseühenduse viiba kaudu.Kui rakendamise ajal ilmnes vigu, kuvatakse veadialoog.Kui soovite, et veadialoogi ei kuvataks, peate valima märkeruudu „Tõkesta kõik lõppkasutaja veateated“.


Lisamärkused:

kasutage rakenduse sulgemiseks Windowsi sulgemisnuppu paremal üleval.


Toetatud opsüsteemid

Microsoft Windows 7

Microsoft Windows 7 64-bitine versioon

Microsoft Windows Server 2008 R2 64-bitine versioon

Microsoft Windows 8

Microsoft Windows 8 64-bitine versioon

Microsoft Windows Server 2012 64-bitine versioon

Microsoft Windows Server 2012 R2 64-bitine versioon

Microsoft Windows 8.1

Microsoft Windows 8.1 64-bitine versioon

Microsoft Windows Server 2016 64-bitine

Microsoft Windows 10

Microsoft Windows 10 64-bitine

Microsoft Windows Server 2019 64-bitine


Käsurea suvandid

Lõppkasutaja paketti võib muuta, lisades käsurea lülitid.Käsurea lüliteid saab kombineerida, eraldades need tühikutega. Kui käsurida sisaldab viga, nagu näiteks vale märk või formaat, siis kuvatakse veateade.Sobimatuid käsurea lüliteid ignoreeritakse.Saadaval on (inglise keeles) ka järgmised käsurea kirjeldused, kui käivitada lõppkasutaja pakett „/?” abil.

Eellaetud paketid toetavad järgmiseid käsurea suvandeid:

/? kuva käsurea info (ainult inglise keeles);

/q ära kuva edenemisriba;

/p printeri otseühenduse viip;

/s tõkesta kõik lõppkasutaja veateated.

Võrguprinteri paketid toetavad järgmiseid käsurea suvandeid:

/? kuva käsurea info (ainult inglise keeles);

/q ära kuva edenemisriba;

/s tõkesta kõik lõppkasutaja veateated

/ip <ip aadress> kasutage printeri identifitseerimiseks kindlat IP-aadressi, nt /ip 120.25.5.56;

/hw <riistvara aadress> kasutage printeri identifitseerimiseks kindlat riistvara aadressi, nt /hw 0001E6299128;

/hn <hostinimi> kasutage printeri identifitseerimiseks kindlat hostinime, nt /hn Myhostname

Hostinimi ei tohi olla pikem kui 255 tähemärki ja võib sisaldada üksnes järgmisi märke:A-Z, a-z, 0-9 ja sidekriips (-);

/pn <pordinimi> kasutage pordinimena kindlat nime, nt /pn HPPort

Pordinimi ei tohi sisaldada tühikuid ega tohi olla pikem kui 128 tähemärki;

/n ”<printeri nimi>” kasutage printeri nimena kindlat printeri nimetust, nt /n "HP LaserJet 8150"

Printeri nimi peab olema jutumärkide vahel, see ei tohi olla pikem kui 40 tähemärki ega tohi sisaldada järgmisi märke: ! # ,

/d määra printer vaikeprinteriks:

/sn ”<jagamisnimi>” lülitage jagamine sisse ja kasutage kindlat nime printeri jagamisnimena, nt /sn ”My shared HP LaserJet 8150”

Printeri jagamisnimi peab olema jutumärkide vahel, see ei tohi olla pikem kui 80 tähemärki ega tohi sisaldada järgmisi märke: / \ : ; “ ? * + = < > [ ]

© Copyright 2019 HP Development Company, L.P.