Úvod

Nástroj HP Driver Deployment Utility (DDU) umožňuje správci vytvořit instalační balík ovladačů pro bezobslužnou instalaci, která nevyžaduje zásah koncového uživatele. Tento nástroj umožňuje přidávat ovladače tiskárny do úložiště ovladačů systému Windows a vytvářet položky ve složce tiskárny. Nástroj Driver Deployment Utility podporuje ovladače tiskárny vytvořené k použití s nástrojem Průvodce přidáním tiskárny společnosti Microsoft. V platnosti jsou všechna certifikační omezení a upozornění společnosti Microsoft.

Rozhraní nástroje je rozděleno do tří částí:

  1. Část „Zdroj balíku“ popisuje typ balíku a umístění ovladače, které chcete vytvořit.
  2. Část „Cíl balíku“ určuje název a umístění instalačního balíku.
  3. Část „Vytvořit balík“ slouží k zahájení procesu vytvoření balíku.


Zdroj balíku

Adresář ovladače

Pomocí tlačítka „Vybrat ovladač…“ vyberte v adresáři s ovladačem soubor INF, a to vyhledáním nebo zadáním souboru. V adresáři musí být pouze jeden balík ovladačů, protože nástroj zkomprimuje do spustitelného souboru všechny soubory nacházející se v adresáři (a podadresářích). Pokud máte stažený komprimovaný balík ovladačů, je třeba jej před použitím nástroje dekomprimovat.

V některých případech se může v adresáři nacházet více souborů ovladačů INF (například jeden pro barevné a druhý pro černobílé tiskárny). V tomto případě se zobrazí další dialogové okno, pomocí něhož můžete vybrat, který z ovladačů chcete zkomprimovat.

Pokud je adresář velký, zobrazí se také upozornění. Tato akce pomáhá zabránit komprimaci více než jednoho ovladače. V tomto bodě se můžete rozhodnout pokračovat, pokud adresář obsahuje všechny požadované nebo potřebné soubory.

Jakmile vyberete adresář s ovladačem a byl nalezen jeden ovladač, zobrazí se informace o adresáři a ovladači.

U ovladačů podporujících konfiguraci předem se aktivuje zaškrtávací pole zobrazené níže. Po výběru tlačítka „Vytvořit balík“ se při výběru tohoto políčka spustí dialogové okno konfigurace.

Typ instalace

„Předběžně načíst ovladač“ – tuto možnost vyberou uživatelé, kteří používají přímé připojení, např. kabel USB. Při instalaci ovladače bude v budoucnu třeba provést připojení prostřednictvím události technologie Plug and Play, avšak balík nainstaluje všechny soubory do úložiště ovladačů systému Windows pro budoucí použití. POZNÁMKA: Je-li pro zařízení nalezeno více ovladačů, operační systém určí, který ovladač je nejvhodnější pro událost technologie Plug and Play, nebo zobrazí uživateli dialogové okno pro výběr ovladače.

Standardně se soubor spustí spolu s dialogovým oknem průběhu. Chcete-li dialogové okno průběhu vypnout, spusťte soubor s parametrem „/q“ na příkazovém řádku. Pokud chcete zobrazit výzvu, aby koncový uživatel po ukončení instalace tiskárnu připojil, zaškrtněte políčko „Zobrazit výzvu k připojení tiskárny“.

U tiskáren se síťovým připojením vyberte možnost „Vytvořit síťový port a instalovat ovladač“. Klepněte na aktivované tlačítko „Nastavení sítě“ a zadejte požadované nastavení sítě.

Nastavení sítě

Je třeba určit síťovou tiskárnu jedním nebo více následujícími způsoby. Nástroj nekomunikuje se zařízením z důvodu zjištění, zda je nastavení platné, avšak provádí kontrolu syntaxe. (Chcete-li povolit opětovné zjištění zařízení, ujistěte se, že je zadána hardwarová adresa.)

Adresa IP:

Zadejte adresu IPv4 nebo IPv6 tiskárny.

Hardwarová adresa:

Zadejte hardwarovou adresu tiskárny.

Název hostitele:

Zadejte název hostitele tiskárny.

Následující nastavení sítě jsou rozšířená. Můžete přijmout výchozí hodnoty zadané předem nebo je libovolně změnit.

Název portu:

Název síťového portu, který bude vytvořen. Pokud název již existuje, bude k němu připojeno číslo, aby byl název jedinečný.

Název tiskárny:

Název tiskárny, který se zobrazí ve složce tiskárny. Pokud název již existuje, bude k němu připojeno číslo, aby byl název jedinečný.

Nastavit tuto tiskárnu jako výchozí:

Ano – při tisku z jiných aplikací bude tiskárna považována za výchozí.

Ne – bude zachována současná výchozí tiskárna, pokud není nainstalována pouze jedna tiskárna.

Sdílet tuto tiskárnu:

Ano – umožní ostatním uživatelům používat tiskárnu.

Název pro sdílení:

Název sdílené tiskárny: Nastavení je aktivní pouze tehdy, je-li u pole „Sdílet tuto tiskárnu“ vybrána možnost Ano. Pokud název již existuje, bude k němu připojeno číslo, aby byl název jedinečný.


Cíl balíku

Chcete-li zadat název a umístění výstupního balíku, stiskněte tlačítko „Uložit jako…“. Nástroj vytvoří balík v adresáři temp a poté jej přesune do konečného umístění. Balík se bude skládat ze dvou souborů, které je třeba dodat současně: soubory EXE a CAB.

Do konečného umístění bude rovněž zkopírován příslušný soubor XML obsahující podrobnosti o balíku. Balík XML je pouze informační a není používán nástrojem DDU během spuštění.


Vytvořit balík

Po zadání všech výše uvedených informací klepněte na tlačítko „Vytvořit balík“. Toto tlačítko není aktivní, dokud nezadáte požadované informace. Po stisknutí tlačítka se aktivuje tlačítko „Storno“ a ukazatel průběhu.

Stisknutím tlačítka „Storno“ ukončíte vytváření balíku.

Soubor se spustí s dialogovým oknem průběhu, a pokud to bude nutné, vyzve uživatele k připojení tiskárny. Pokud během spuštění nastane chyba, zobrazí se chybová zpráva. Chcete-li zobrazení chybové zprávy zamezit, zaškrtněte políčko „Nezobrazovat chybové zprávy pro koncové uživatele“.


Doplňující poznámky:

Chcete-li tuto aplikaci zavřít, použijte tlačítko systému Windows pro zavření, které se nachází v pravém horním rohu.


Podporované operační systémy

Microsoft Windows 7

Microsoft Windows 7 (64bitový)

Microsoft Windows Server 2008 R2 (64bitový)

Microsoft Windows 8

Microsoft Windows 8 (64bitový)

Microsoft Windows Server 2012 (64bitový)

Microsoft Windows Server 2012 R2 (64bitový)

Microsoft Windows 8.1

Microsoft Windows 8.1 (64bitový)

Microsoft Windows Server 2016 64-Bit Edition

Microsoft Windows 10

Microsoft Windows 10 64-Bit Edition

Microsoft Windows Server 2019 64-Bit Edition


Možnosti příkazového řádku

Balík pro koncového uživatele může být pozměněn přidáním parametrů na příkazovém řádku. Parametry příkazového řádku mohou být kombinovány, pokud jsou odděleny mezerami. Chybové hlášení se zobrazí, pokud příkazový řádek obsahuje chybu, například neplatný znak nebo nesprávné formátování. Nesprávné parametry příkazového řádku jsou ignorovány. Následující popis příkazového řádku je dostupný (v angličtině) spuštěním balíku pro koncového uživatele s parametrem „/?“.

Předběžně načtené balíky podporují následující možnosti příkazového řádku:

/? zobrazit informace příkazového řádku (pouze v angličtině)

/q potlačit ukazatel průběhu

/p vyzvat uživatele k připojení tiskárny

/s nezobrazovat chybové zprávy pro koncové uživatele

Balíky síťové tiskárny podporují následující možnosti příkazového řádku:

/? zobrazit informace příkazového řádku (pouze v angličtině)

/q potlačit ukazatel průběhu

/s nezobrazovat chybové zprávy pro koncové uživatele

/ip <adresa IP> použít zadanou adresu IP k určení tiskárny, např. /ip 120.25.5.56

/hw <hardwarová adresa> použít zadanou hardwarovou adresu k určení tiskárny, např. /hw 0001E6299128

/hn <název hostitele> použít zadaný název hostitele k určení tiskárny, např. /hn Mujhostitel

Délka názvu hostitele nesmí překročit 255 znaků a může obsahovat pouze následující znaky:A-Z, a-z, 0-9 a pomlčku (-).

/pn <název portu> použít zadaný název jako název portu, např. /pn HPPort

Název portu nesmí obsahovat mezery a jeho maximální délka je 128 znaků.

/n ”<název tiskárny>” použít zadaný název jako název tiskárny, např. /n "HP LaserJet 8150"

Název tiskárny musí být v uvozovkách, jeho délka nesmí překročit 40 znaků a nesmí obsahovat tyto znaky: ! # ,

/d nastavit tuto tiskárnu jako výchozí

/sn ”<název pro sdílení>” povolit sdílení a použít zadaný název jako název pro sdílení, např. /sn ”Sdílená tiskárna HP LaserJet 8150”

Název pro sdílení musí být v uvozovkách, jeho délka nesmí překročit 80 znaků a nesmí obsahovat tyto znaky: / \ : ; “ ? * + = < > [ ]

© Copyright 2019 HP Development Company, L.P.