Introducció

L'HP Driver Deployment Utility (DDU) permet que els administradors creïn un paquet d'instal·lació de controladors perquè els usuaris finals puguin fer una instal·lació desatesa. Aquesta utilitat permet afegir controladors d'impressió al magatzem de controladors del Windows i crear entrades a la carpeta d'impressores. La Driver Deployment Utility admet controladors d'impressió dissenyats per a fer-los servir amb l'auxiliar d'addició d'impressores de Microsoft. Són aplicables totes les alertes i restriccions de certificació de Microsoft.

La interfície està dividida en tres seccions:

  1. "Origen del paquet" indica el tipus de paquet i la ubicació del controlador que voleu crear.
  2. "Destinació del paquet" identifica el nom i la ubicació del paquet d'instal·lació.
  3. "Crea el paquet" inicia el procés de creació del paquet.


Origen del paquet

Directori del controlador

Feu servir el botó "Seleccioneu un controlador..." per a seleccionar un fitxer .inf al directori del controlador buscant-lo o escrivint-ne el nom. Només hauríeu de tenir un paquet de controlador en aquest directori, ja que aquesta utilitat empaquetarà tots els fitxers que es trobin en aquest directori (i també els subdirectoris corresponents) en un fitxer executable. Si heu baixat un paquet de controlador comprimit, l'heu de descomprimir abans de fer servir aquesta utilitat.

En alguns casos, podeu trobar que teniu més d'un fitxer .inf de controladors al directori (a vegades un és per a les impressores en color i l'altre per a les impressores monocromes). En aquest cas, un quadre de diàleg addicional us permetrà seleccionar el controlador que voleu empaquetar.

També se us obrirà una finestra d'advertència si el directori és gran. Així s'evita que s'empaqueti més d'un controlador. En aquest punt, podeu optar per continuar si el directori conté tots els fitxers que voleu o necessiteu.

Un cop hagueu seleccionat el directori del controlador i s'hi hagi trobat un controlador, es mostra la informació del directori i del controlador.

En el cas dels controladors que admeten preconfiguració, la casella de selecció de sota estarà habilitada. Si se selecciona, s'executarà un quadre de diàleg de configuració en prémer el botó "Crea el paquet".

Tipus d'instal·lació

Per als usuaris que facin servir una connexió directa, com ara un cable USB, s'ha de seleccionar l'opció "Precarrega el controlador". Caldrà una posterior integració automàtica per a instal·lar el controlador, però aquest paquet instal·larà tots els fitxers al magatzem de controladors del Windows per a usos posteriors. NOTA: Si hi ha diversos controladors per a un dispositiu, el sistema operatiu determinarà quin és el millor per a la integració automàtica o bé mostrarà un quadre de diàleg de selecció del controlador.

Per defecte, el fitxer executable s'executa amb un diàleg de progrés. Per a desactivar el diàleg de progrés, executeu el fitxer executable amb "/q" a la línia d'ordres. Si voleu indicar a l'usuari final que connecti la impressora en acabar la instal·lació, seleccioneu la casella de selecció "Demana que es connecti la impressora".

Per a impressores que fan servir una connexió de xarxa, seleccioneu l'opció "Crea el port de xarxa i instal·la el controlador". S'habilitarà el botó "Paràmetres de xarxa"; feu-hi clic per a introduir els paràmetres de xarxa necessaris.

Paràmetres de xarxa

Identifiqueu la impressora de xarxa mitjançant un o més dels mètodes següents. Aquesta utilitat no es comunica amb el dispositiu per a determinar si els paràmetres són vàlids, però sí que comprova la sintaxi. Per a habilitar que es torni a detectar el dispositiu, comproveu que s'ha especificat l'adreça de maquinari.

Adreça IP:

Introduïu l'adreça IPv4 o IPv6 de la impressora.

Adreça de maquinari:

Introduïu l'adreça de maquinari de la impressora.

Nom del sistema principal:

Introduïu el nom del sistema principal de la impressora.

Els paràmetres de xarxa següents són addicionals: podeu acceptar els valors predeterminats o canviar-los.

Nom del port:

Aquest paràmetre correspon al nom del port de xarxa que es crearà. Si el nom ja existeix, se li afegirà un número per tal de fer-lo únic.

Nom de la impressora:

Aquest paràmetre correspon al nom de la impressora que apareixerà a la carpeta d'impressores. Si el nom ja existeix, se li afegirà un número per tal de fer-lo únic.

Estableix aquesta impressora com a predeterminada:

Sí: establirà la impressora com a predeterminada en imprimir des d'altres aplicacions.

No: mantindrà el valor per defecte, tret que sigui l'única impressora instal·lada.

Comparteix aquesta impressora:

Sí: permetrà que altres usuaris facin servir aquesta impressora.

Nom de recurs compartit:

Nom de recurs compartit de la impressora. Només habilitat si el valor de l'opció "Comparteix aquesta impressora" és Sí. Si el nom ja existeix, se li afegirà un número per tal de fer-lo únic.


Destinació del paquet

Seleccioneu el botó "Anomena i desa…" per a introduir el nom i la ubicació del paquet resultant. La utilitat crearà el paquet al directori temporal i tot seguit el mourà a la ubicació final. El paquet inclourà dos fitxers que cal proporcionar conjuntament: un .exe i un .cab.

També es copiarà a la ubicació final un fitxer de descripció .xml associat que conté els detalls del paquet. El paquet .xml només és informatiu, la DDU no el fa servir durant l'execució.


Crea el paquet

Seleccioneu el botó "Crea el paquet" quan hagueu introduït tota la informació esmentada. Aquest botó estarà inhabilitat fins que no s'hagi introduït la informació necessària. Un cop seleccionat, s'habilitarà el botó "Anul·la" i la barra "Progrés".

Per a aturar la creació del paquet, seleccioneu el botó "Anul·la".

El fitxer executable s'executarà amb un diàleg de progrés i, si es demana, un missatge per a la impressora de connexió directa. Si hi ha cap error en l'execució, apareixerà un quadre de diàleg d'error. Per a suprimir-lo, seleccioneu la casella de selecció "Suprimeix tots els missatges d'error per a l'usuari final".


Notes addicionals

Per a tancar aquesta aplicació, feu servir el botó de tancar del Windows, situat a l'extrem superior dret.


SO compatibles

Microsoft Windows 7

Microsoft Windows 7 edició de 64 bits

Microsoft Windows Server 2008 R2 edició de 64 bits

Microsoft Windows 8

Microsoft Windows 8 edició de 64 bits

Microsoft Windows Server 2012 edició de 64 bits

Microsoft Windows Server 2012 R2 edició de 64 bits

Microsoft Windows 8.1

Microsoft Windows 8.1 edició de 64 bits

Microsoft Windows Server 2016, edició de 64 bits

Microsoft Windows 10

Microsoft Windows 10, edició de 64 bits

Microsoft Windows Server 2019, edició de 64 bits


Opcions de la línia d'ordres

Podeu modificar el paquet d'usuari final afegint modificadors de la línia d'ordres. Els modificadors de la línia d'ordres es poden combinar si els separeu amb espais. Si la línia d'ordres conté un error, com ara un caràcter no vàlid o un format incorrecte, es mostra un missatge d'error. Els modificadors de la línia d'ordres incorrectes s'ignoren. També hi ha disponible la següent descripció de la línia d'ordres (en anglès) si executeu el paquet d'usuari final amb "/?".

Els paquets precarregats admeten les següents opcions de línia d'ordres:

/? Mostra la informació de la línia d'ordres (només en anglès)

/q Suprimeix la barra de progrés

/p Demana a l'usuari que connecti la impressora

/s Suprimeix els missatges d'error per a l'usuari final

Els paquets d'impressora de xarxa admeten les següents opcions de línia d'ordres:

/? Mostra la informació de la línia d'ordres (només en anglès)

/q Suprimeix la barra de progrés

/s Suprimeix els missatges d'error per a l'usuari final

/ip <adreça IP> Utilitza l'adreça IP especificada per a identificar la impressora. Per exemple: /ip 120.25.5.56

/hw <adreça de maquinari> Utilitza l'adreça de maquinari especificada per a identificar la impressora. Per exemple: /hw 0001E6299128

/hn <nom sistema principal> Utilitza el nom del sistema principal especificat per a identificar la impressora. Per exemple: /hn Nom_del_meu_sistema_principal

El nom de sistema principal no pot tenir més de 255 caràcters, i només pot contenir els següents caràcters: A-Z, a-z, 0-9 i el guió (-).

/pn <nom port> Utilitza el nom especificat com a nom del port. Per exemple: /pn HPPort

El nom del port no pot contenir espais ni tenir més de 128 caràcters.

/n "<nom impressora>" Utilitza el nom especificat com a nom de la impressora. Per exemple: /n "HP LaserJet 8150"

El nom de la impressora s'ha d'especificar entre cometes, no pot tenir més de 40 caràcters ni pot contenir cap d'aquests caràcters especials: ! # ,

/d Estableix aquesta impressora com a predeterminada

/sn "<nom recurs compartit>" Activa la compartició i fa servir el nom especificat com a nom de recurs compartit per a la impressora. Per exemple: /sn "La meva impressora compartida HP LaserJet 8150"

El nom de recurs compartit s'ha d'especificar entre cometes, no pot tenir més de 80 caràcters ni pot contenir cap d'aquests caràcters especials: / \ : ; “ ? * + = < > [ ]

© Copyright 2019 HP Development Company, L.P.