مقدمة

تقوم HP Driver Deployment Utility (DDU) بتمكين المسؤول من إنشاء حزمة تثبيت لبرنامج التشغيل للتثبيت غير المراقب من قبل المستخدمين. تدعم هذه الأداة المساعدة إضافة برامج تشغيل الطباعة إلى مخزن برنامج تشغيل Windows وإنشاء إدخالات في مجلد "الطابعة". تدعم Driver Deployment Utility برامج تشغيل الطباعة التي تم تصميمها لكي تُستخدم مع معالج "إضافة طابعة" من Microsoft. تم تطبيق كافة تنبيهات وتقييدات شهادة Microsoft.

تم تقسيم واجهة المستخدم إلى ثلاثة أقسام:

  1. 'الحزمة المصدر' يوضح نوع الحزمة وموقع برنامج التشغيل المرغوب إنشائه
  2. 'الحزمة الهدف' يعرف اسم حزمة التثبيت وموقعها
  3. 'إنشاء حزمة' يقوم بعملية إنشاء الحزمة


الحزمة المصدر

دليل برنامج التشغيل

استخدم الزر 'تحديد برنامج التشغيل...' لتحديد ملف inf في دليل برنامج التشغيل بواسطة الاستعراض إليه أو الكتابة فيه. يجب أن يكون لديك حزمة برنامج تشغيل واحدة في هذا الدليل لأن الأداة المساعدة ستقوم بتجميع كافة الملفات الموجودة في هذا الدليل (والدلائل الفرعية) في الملف التنفيذي. إذا قمت بتنزيل حزمة برنامج تشغيل مضغوطة، يجب أن تقوم بتوسيعها قبل استخدام هذه الأداة المساعدة.

في بعض الحالات، قد يكون لديك ملفات برنامج تشغيل متعددة من نوع inf في الدليل (يوجد في بعض الأحيان ملف للطابعات الملونة وملف آخر للطابعات أحادية اللون). في هذه الحالة، يسمح لك مربع حوار إضافي بتحديد برنامج التشغيل الذي تريد ضمه للحزمة.

كما ستحصل على تحذير إذا كان الدليل حجمه كبير. يساعد هذا الإجراء على منع حزم أكثر من برنامج تشغيل واحد. قد تختار المتابعة حتى هذه النقطة في حالة اشتمال الدليل على كافة الملفات المطلوبة أو المرغوبة.

بمجرد أن يتم تحديد دليل برنامج التشغيل، والعثور على برنامج تشغيل واحد، يتم عرض معلومات الدليل وبرنامج التشغيل.

بالنسبة لبرامج التشغيل التي تدعم التكوين المسبق، يتم تمكين خانة الاختيار الموجودة أدناه. بتحديد خانة الاختيار هذه سيتم تشغيل مربع حوار تكوين بعد تحديد الزر 'إنشاء حزمة'.

نوع التثبيت

'التحميل المسبق لبرنامج التشغيل' – هو الخيار الذي سيقوم بتحديده المستخدمين الذين يستخدمون اتصالاً مباشراً، مثل كبل من نوع USB. سيكون من الضروري لحدث "توصيل وتشغيل" مستقبلي تثبيت برنامج التشغيل، إلا أنه سيتم تثبيت كافة الملفات في مخزن برنامج تشغيل Windows بواسطة هذه الحزمة للاستخدام في المستقبل. ملاحظة: في حالة وجود العديد من برامج التشغيل لأحد الأجهزة، سيقوم "نظام التشغيل" بتحديد برنامج التشغيل الأكثر ملائمة لحدث "التوصيل والتشغيل"، أو تقديم مربع حوار للمستخدم خاص بتحديد برنامج التشغيل.

يتم افتراضياً تشغيل الملف التنفيذي مع مربع حوار التقدم. لإيقاف تشغيل مربع حوار التقدم، قم بتشغيل الملف التنفيذي مع الأمر “/q” الموجود على سطر الأوامر. إذا كنت ترغب في مطالبة المستخدم بتوصيل الطابعة في نهاية التثبيت، حدد خانة الاختيار 'إظهار مطالبة لتوصيل الطابعة'.

بالنسبة للطابعات التي تستخدم اتصال شبكة، حدد الخيار ' إنشاء منفذ الشبكة وتثبيت برنامج التشغيل'. يتم تمكين الزر 'إعدادات الشبكة'، ويجب أن تقوم بالنقر فوقه لإدخال إعدادات الشبكة المطلوبة.

إعدادات الشبكة

يجب أن تقوم بتعريف طابعة الشبكة بطريقة واحدة أو أكثر من الطرق التالية. لا تتصل هذه الأداة المساعدة بالجهاز لتحديد ما إذا كانت الإعدادات صالحة أم لا، لكنها تقوم بتدقيق بناء الجملة. (لتمكين إعادة اكتشاف الجهاز، تأكد من تحديد "عنوان الجهاز").

عنوان IP:

إدخال عنوان IPv4 أو IPv6 الخاص بالطابعة

عنوان الجهاز:

إدخال عنوان الجهاز الخاص بالطابعة

اسم المضيف:

إدخال اسم المضيف الخاص بالطابعة

تعد إعدادات الشبكة التالية إعدادات إضافية. يمكنك قبول القيم الافتراضية التي تم إدخالها مسبقاً أو تغيير أية قيمة منها.

اسم المنفذ:

هو اسم منفذ الشبكة الذي سيتم إنشاؤه. إذا كان الاسم موجود بالفعل، سيتم إلحاق رقم به لجعله فريداً.

اسم الطابعة:

هو اسم الطابعة الذي سيظهر في مجلد "الطابعات". إذا كان الاسم موجود بالفعل، سيتم إلحاق رقم به لجعله فريداً.

تعيين الطابعة كطابعة افتراضية:

نعم – سيجعل هذه الطابعة الطابعة الافتراضية عند الطباعة من تطبيقات أخرى.

لا – ستحتفظ بالطابعة الافتراضية الحالية، إلا إذا كانت هذه هي الطابعة الوحيدة المثبتة.

مشاركة هذه الطابعة:

نعم – ستسمح للمستخدمين الآخرين باستخدام هذه الطابعة.

اسم المشاركة:

هو اسم المشاركة للطابعة. يتم تمكينه فقط إذا كانت حالة 'مشاركة هذه الطابعة' هي "نعم". إذا كان الاسم موجود بالفعل، سيتم إلحاق رقم به لجعله فريداً.


الحزمة الهدف

حدد الزر 'حفظ باسم...' لإدخال اسم حزمة الإخراج وموقعها. ستقوم هذه الأداة المساعدة بإنشاء الحزمة في الدليل temp ثم نقلها إلى الموقع النهائي.ستتكون الحزمة من ملفين يلزم تسليمهما معًا:ملف .exe وملف .cab.

سيتم كذلك نسخ إحدى ملفات وصف xml المتطابقة التي تحتوي على تفاصيل الحزمة إلى الموقع النهائي. تُُعد حزمة xml إعلامية فقط، ولا يتم استخدامها من قبل DDU أثناء التنفيذ.


إنشاء حزمة

حدد الزر 'إنشاء حزمة' عند قيامك بإدخال كافة المعلومات أعلاه. يتم تعطيل هذا الزر حتى تقوم بإدخال المعلومات المطلوبة.بمجرد تحديده، يتم تمكين الزر 'إلغاء الأمر' وشريط 'التقدم'.

لإيقاف إنشاء الحزمة، حدد الزر 'إلغاء الأمر'.

يتم تشغيل الملف التنفيذي مع ظهور مربع حوار التقدم، وإذا استدعى الأمر، تظهر مطالبة للمستخدم بإجراء اتصال مباشر بالطابعة. في حالة مصادفة خطأ أثناء التنفيذ، سيظهر مربع حوار خطأ. لمنع ظهور مربع حوار الخطأ، يجب أن تقوم بتحديد خانة الاختيار 'منع كافة رسائل الخطأ للمستخدمين'.


ملاحظات إضافية

لغلق هذا التطبيق استخدم زر إغلاق نظام التشغيل Windows الموجود في أعلى الزاوية اليمنى.


نظم التشغيل المدعومة

Microsoft Windows 7

Microsoft Windows 7‏ إصدار 64‏ بت

‎Microsoft Windows Server 2008 R2‎‏ إصدار 64‏ بت

Microsoft Windows 8

Microsoft Windows 8‏ إصدار 64‏ بت

Microsoft Windows Server 2012‏ إصدار 64‏ بت

‎Microsoft Windows Server 2012 R2‎‏ إصدار 64‏ بت

Microsoft Windows 8.1

Microsoft Windows 8.1‏ إصدار 64‏ بت

Microsoft Windows Server 2016‏ إصدار 64‏ بت

Microsoft Windows 10‎‏

Microsoft Windows 10‏ إصدار 64‏ بت

Microsoft Windows Server 2019‏ إصدار 64‏ بت


خيارات سطر الأوامر

يمكن تعديل حزمة المستخدم بإضافة رموز التبديل في سطر الأوامر. يمكن تجميع رموز التبديل في سطر الأوامر في حالة فصلها بمسافات. يتم عرض رسالة خطأ في حالة اشتمال سطر الأوامر على خطأ، على سبيل المثال حرف غير صالح أو تنسيق غير ملائم. يتم تجاهل رموز التبديل غير الملائمة في سطر الأوامر. يتوفر أيضًا وصف سطر الأوامر التالي (باللغة الإنجليزية) بواسطة تشغيل حزمة المستخدم مع الأمر “/?”.

تدعم الحزم التي تم تحميلها مسبقًا خيارات أسطر الأوامر التالية:

/? عرض معلومات سطر الأوامر (باللغة الإنجليزية فقط)

/q منع شريط التقدم

/p مطالبة المستخدم بتوصيل الطابعة

/s منع رسائل الخطأ للمستخدمين

تدعم حزم الطابعات المتصلة بالشبكة خيارات أسطر الأوامر التالية:

/? عرض معلومات سطر الأوامر (باللغة الإنجليزية فقط)

/q منع شريط التقدم

/s منع رسائل الخطأ للمستخدمين

/ip <ip address>استخدام عنوان IP المحدد لتعريف الطابعة، على سبيل المثال /ip 120.25.5.56

/hw <hardware address>استخدام عنوان الجهاز المحدد لتعريف الطابعة، على سبيل المثال /hw 0001E6299128

/hn <hostname>استخدام اسم المضيف المحدد لتعريف الطابعة، على سبيل المثال /hn Myhostname

يجب ألا يتجاوز طول اسم المضيف 225 حرفًا ويمكن أن يشتمل فقط على الأحرف التالية:A-Z، و a-z، و0-9 والشرطة (-).

/pn <portname>استخدام اسم محدد كاسم المنفذ، على سبيل المثال /pn HPPort

يجب ألا يتضمن اسم المنفذ أية مسافات ويجب ألا يتجاوز طوله 128 حرفًا.

/n ”<printername>”استخدام اسم محدد كاسم الطابعة، على سبيل المثال /n "HP LaserJet 8150"

يجب أن يتم احتواء اسم الطابعة في علامات الاقتباس، ويجب ألا يتجاوز طوله 40 حرفًا كما يجب ألا يحتوي على أية من هذه الأحرف الخاصة: ! # ,

/d تعيين الطابعة كطابعة افتراضية

/sn ”<sharename>” تشغيل المشاركة واستخدام الاسم المحدد كاسم المشاركة الخاصة بالطابعة، على سبيل المثال /sn ”My shared HP LaserJet 8150”

يجب أن يتم احتواء اسم المشاركة في علامات الاقتباس، ويجب ألا يتجاوز طوله 80 حرفًا كما يجب ألا يحتوي على أية من هذه الأحرف الخاصة: / \ : ; “ ? * + = < > [ ]

© Copyright 2019 HP Development Company, L.P.