簡介

HP Driver Deployment Utility (DDU) 可允許管理員建立驅動程式安裝套件，以讓使用者進行無訊息、且無須介入的安裝。 此公用程式支援新增印表機驅動程式至 Windows 驅動程式儲存區以及在「印表機」的資料夾中建立項目。 Driver Deployment Utility 支援為搭配Microsoft 的「新增印表機精靈」使用而設計的印表機驅動程式。 所有 Microsoft 憑證的條件限制和警示均會套用。

使用者介面 (UI) 可分為 3 個區段：

  1. 「套件來源」說明套件類型和所要建立的驅動程式位置
  2. 「套件目標」辨識安裝套件的名稱和位置
  3. 「建立套件」啟動套件建立的程序


套件來源

驅動程式目錄

使用「選取驅動程式…」按鈕瀏覽至驅動程式目錄後選取 inf 檔，或者輸入該檔名。您在此目錄中應只有一個驅動程式套件，因為此公用程式會將此目錄中（以及子目錄）找到的所有檔案封裝為可執行檔。 如果您下載了壓縮的驅動程式套件，則在使用此公用程式之前須將其解壓縮。

在某些情況下，您在此目錄中會有多個 inf 檔（有時候一個是給彩色印表機使用，另一個是給黑白印表機使用）。 若是此種狀況，會有另一個對話方塊出現讓您選取要封裝的驅動程式。

如果您的目錄很大，同時還會收到警告訊息。 這是要協助您避免封裝一個以上的驅動程式。 如果該目錄包含所有想要或者所需的檔案，您在這時候可以選擇是否繼續。

一旦選取了驅動程式目錄，而且也找到了一個驅動程式，就會顯示目錄和驅動程式資訊。

若是支援預先設定的驅動程式，下方核取方塊會是啟用狀態。 選取此項將會在選取了「建立套件」按鈕之後，執行設定對話。

安裝類型

「預先載入驅動程式」是一個可供使用直接連線（例如 USB 纜線）的使用者選取用的選項。 日後的「隨插即用」事件會需要安裝驅動程式，但是所有檔案均會被此套件安裝到 Windows 驅動程式儲存區中，以供日後使用。 注意： 如果一個裝置中找到多個驅動程式，作業系統會決定使用一個最適合「隨插即用」的驅動程式，或者顯示驅動程式選取對話讓使用者做選擇。

依照預設，可執行檔的執行含有進度對話。 若要關閉進度對話，請執行其指令行含有「/q」的可執行檔。 如果您想要向使用者提示，以便在安裝結束時連接印表機，則請選取「出現提示以連接印表機」。

對於使用網路連接的印表機，則請選取「建立網路連接埠和安裝驅動程式」選項。 「網路設定」按鈕會變成啟用狀態，而您應按一下該按鈕，以輸入所需的網路設定。

網路設定值

您必須要以下列其中一個或多個方法來識別網路印表機。 此公用程式不會與裝置通訊，以判斷設定是否有效，但是會執行語法檢查 （若要啟用裝置的重新偵測，請確定指定了「硬體位址」）。

IP 位址：

輸入印表機的 IPv4 或 IPv6 位址

硬體位址：

輸入印表機的硬體位址

主機名：

輸入印表機的主機名

下列網路設定值是額外的設定。 您可以接受預先輸入的預設值，或變更這些預設值。

連接埠名稱：

這是將會建立的網路連接埠名稱。 如果已經有此名稱存在，則會在其後加上數字使其成為唯一。

印表機名稱：

這是將會出現在「印表機」資料夾中之印表機的名稱。 如果已經有此名稱存在，則會在其後加上數字使其成為唯一。

將此印表機設為預設印表機：

是 - 當從其他應用程式列印時會將此印表機設為預設印表機。

否 - 會保持目前的預設值，除非這是唯一安裝的印表機。

共用此印表機：

是 - 允許其他人使用此印表機。

共用名稱：

印表機共用的名稱。 唯有「共用此印表機」設定為是時，才會啟用。 如果已經有此名稱存在，則會在其後加上數字使其成為唯一。


套件目標

選取「另存新檔…」按鈕以輸入輸出套件的名稱和位置。 公用程式會在 temp 目錄中建立套件，然後將其移到最終位置。套件會包含 2 個需要一起提交的檔案：一個 .exe 和一個 .cab。

包含套件詳細資訊的對應 xml 說明檔也會複製到最終位置。 xml 套件僅為提供資訊，在執行期間 DDU 不會使用此套件。


建立套件

當您輸入了上述所有資訊之後，請選取「建立套件」按鈕。 此按鈕在您輸入了所需的資訊之後，才會啟用。一旦選取之後，「取消」按鈕和「進度」列將會啟用。

若要停止建立套件，請選取「取消」按鈕

可執行檔將以顯示進度對話的方式執行，若是直接連接印表機的使用者，則會出現提示。 如果在執行時出現錯誤，便會出現錯誤的對話方塊。 若要隱藏此錯誤對話方塊，您應選取「隱藏所有使用者錯誤訊息」核取方塊。


其他附註：

若要關閉此應用程式，請使用右上方的 Windows 關閉按鈕。


支援的作業系統

Microsoft Windows 7

Microsoft Windows 7 64 位元版本

Microsoft Windows Server 2008 R2 64 位元版本

Microsoft Windows 8

Microsoft Windows 8 64 位元版本

Microsoft Windows Server 2012 64 位元版本

Microsoft Windows Server 2012 R2 64 位元版本

Microsoft Windows 8.1

Microsoft Windows 8.1 64 位元版本

Microsoft Windows Server 2016 64 位元版本

Microsoft Windows 10

Microsoft Windows 10 64 位元版本

Microsoft Windows Server 2019 64 位元版本


指令行選項

使用者套件可透過新增指令行參數來加以修改。 指令行參數若是以空格區分，則可予以組合。 如果指令行含有錯誤（例如字元無效或格式錯誤），會顯示錯誤訊息。 不正確的指令行參數會予以忽略。 執行含有「/?」的使用者套件亦可顯示下列指令行說明（英文）。

預先載入套件支援下列指令行選項：

/? 顯示指令行資訊（僅以英文顯示）

/q 隱藏進度列

/p 提示使用者連接印表機

/s 隱藏使用者錯誤訊息

網路印表機套件支援下列指令行選項：

/? 顯示指令行資訊（僅以英文顯示）

/q 隱藏進度列

/s 隱藏使用者錯誤訊息

/ip <ip 位址> 使用指定的 IP 位址來識別印表機，例如 /ip 120.25.5.56

/hw <硬體位址> 使用指定的硬體位址來識別印表機，例如 /hw 0001E6299128

/hn <主機名> 使用指定的主機名來識別印表機，例如 /hn Myhostname

主機名長度不可超過 255 個字元，並且僅可包含下列字元：A-Z、a-z、0-9 和破折號 (-)。

/pn <連接埠名稱>使用指定的名稱做為連接埠名稱，例如 /pn HPPort

連接埠名稱不可包含空格，並且長度不可超過 128 個字元。

/n ”<印表機名稱>” 使用指定的名稱做為印表機名稱，例如 /n "HP LaserJet 8150"

印表機名稱必須以引號包住、長度不可超過 40 個字元，並且不可包含下列任何特殊字元： ! # ,

/d 將此印表機設為預設印表機

/sn ”<共用名稱>” 開啟共用功能，並使用指定的名稱做為印表機的共用名稱，例如 /sn ”My shared HP LaserJet 8150”

共用名稱必須以引號包住、長度不可超過 80 個字元，並且不可包含下列任何特殊字元： / \ : ; “ ? * + = < > [ ]

© Copyright 2019 HP Development Company, L.P.