Introducción

HP Driver Deployment Utility (DDU) permite a un administrador crear un paquete de instalación de controladores con el fin de que el usuario final pueda llevar a cabo una instalación silenciosa y desatendida. Esta utilidad admite la incorporación de controladores al almacén de controladores de Windows y la creación de entradas en la carpeta de la impresora. Driver Deployment Utility admite controladores de impresora diseñados para usarse con el Asistente para agregar impresoras de Microsoft.Se aplican todas las restricciones y alertas de certificación de Windows.

La interfaz de usuario se divide en tres secciones:

  1. “Origen del paquete” describe el tipo de paquete y la ubicación del paquete de instalación.
  2. “Destino del paquete” identifica el nombre y la ubicación del paquete de instalación.
  3. “Crear paquete” inicia el proceso de creación del paquete.


Origen del paquete

Directorio de controladores

Utilice el botón “Seleccionar controlador…” para seleccionar un archivo .inf del directorio de controladores, navegando hasta el archivo o bien introduciendo su nombre. Es preciso que disponga únicamente de un paquete de controladores en este directorio, ya que esta utilidad incluirá en el archivo ejecutable todos los archivos que encuentre en el directorio (y subdirectorios). Si ha descargado un paquete de controladores comprimido, deberá extraerlo antes de utilizar esta utilidad.

En algunos casos, puede que disponga de varios archivos .inf de controlador en el directorio (a veces un archivo corresponde a las impresoras a color y otro a las impresoras monocromáticas). En ese caso, un cuadro de diálogo adicional le permitirá seleccionar el controlador que desee incluir en el paquete.

Asimismo, se mostrará una advertencia si el directorio es demasiado grande. De este modo, se evitará incluir en el paquete más de un controlador. Llegado este punto, podrá decidir si desea continuar.

Una vez seleccionado el directorio de controladores y localizado el controlador, se visualizará la información correspondiente.

En el caso de los controladores que admitan preconfiguración, la siguiente casilla de verificación estará desactivada. Si selecciona esta casilla, aparecerá un diálogo de configuración después de seleccionar el botón "Crear paquete".

Tipo de instalación

Para los usuarios que vayan a utilizar una conexión directa, por ejemplo, un cable USB, debe seleccionarse la opción "Precargar el controlador ". Para instalar el controlador, será necesario un posterior evento Plug and Play. No obstante, este paquete instalará todos los archivos en el almacén de controladores de Windows para un uso futuro. NOTA: Si se encuentran varios controladores para un dispositivo, el sistema operativo determinará qué controlador es el más adecuado para Plug and Play o mostrará un cuadro de diálogo de selección del controlador.

Por defecto, el archivo ejecutable se ejecuta con un diálogo con una barra de progreso. Para desactivar el diálogo, ejecute el archivo con la opción “/q” en la línea de comandos. Si desea solicitar al usuario final que conecte la impresora al final de la instalación, seleccione la casilla de verificación "Mostrar un mensaje de solicitud de conexión de la impresora".

En el caso de las impresoras que utilicen una conexión de red, seleccione la opción "Crear el puerto de red e instalar el controlador". Se activará el botón "Configuración de red", en el que deberá hacer clic para introducir la configuración de red necesaria.

Configuración de red

Debe identificar la impresora de red mediante uno o varios de los siguientes métodos. Esta utilidad no se comunica con el dispositivo para determinar si la configuración es válida, pero sí lleva a cabo una comprobación de la sintaxis. (Para activar que se vuelva a detectar el dispositivo, compruebe que se ha especificado la dirección de hardware.)

Dirección IP:

Introduzca la dirección IPv4 o IPv6 de la impresora

Dirección de hardware:

Introduzca la dirección de hardware de la impresora

Nombre de host:

Introduzca el nombre de host de la impresora.

Las siguientes configuraciones de red son adicionales. Puede aceptar los valores introducidos por defecto o bien modificar cualquiera de ellos.

Nombre del puerto:

Se trata del nombre del puerto de red que se creará. Si el nombre ya existe, se añadirá un número para hacer que sea único.

Nombre de la impresora

Se trata del nombre que aparecerá en la carpeta de impresoras. Si el nombre ya existe, se añadirá un número para hacer que sea único.

Establecer esta impresora como predeterminada:

Sí: esta impresora se convertirá en la opción predeterminada al imprimir desde otras aplicaciones.

No: se mantendrá la impresora predeterminada actual, a menos que se trate de la única impresora instalada.

Compartir esta impresora:

Sí: esta impresora podrá ser utilizada por otros usuarios.

Nombre de recurso compartido:

Nombre de la impresora compartida. Esta opción está activada únicamente si "Compartir esta impresora" está definido como Sí. Si el nombre ya existe, se añadirá un número para hacer que sea único.


Destino del paquete

Seleccione el botón "Guardar como..." para introducir el nombre y la ubicación del paquete de salida. La utilidad creará el paquete en el directorio temporal y, a continuación, lo moverá a la ubicación final.El paquete constará de dos archivos que deben proporcionarse conjuntamente:un .exe y un .cab.

En la ubicación final también se copiará un archivo .xml idéntico con los detalles del paquete. El paquete xml es solamente informativo y el DDU no lo utiliza durante la ejecución.


Crear paquete

Seleccione el botón "Crear paquete" una vez que haya introducido toda la información indicada anteriormente. Este botón permanecerá inhabilitado hasta que no haya introducido toda la información necesaria.Una vez seleccionado, se habilitará el botón "Cancelar" y se activará la barra "Progreso".

Para detener la creación del paquete, seleccione el botón “Cancelar”.

El archivo se ejecutará con un diálogo con una barra de progreso, y si se solicita, aparecerá un mensaje de notificación al usuario para una impresora de conexión directa. Si se produce un error durante la ejecución, aparecerá un diálogo de error. Para suprimir el diálogo de error, seleccione la casilla de verificación "Suprimir todos los mensajes de error del usuario final".


Notas adicionales:

Para cerrar esta aplicación, utilice el botón de cierre de Windows situado en el vértice superior derecho.


SO admitidos

Microsoft Windows 7

Microsoft Windows 7 Edición de 64 bits

Microsoft Windows Server 2008 R2 Edición de 64 bits

Microsoft Windows 8

Microsoft Windows 8 Edición de 64 bits

Microsoft Windows Server 2012 Edición de 64 bits

Microsoft Windows Server 2012 R2 Edición de 64 bits

Microsoft Windows 8.1

Microsoft Windows 8.1 Edición de 64 bits

Microsoft Windows Server 2016, edición de 64 bits

Microsoft Windows 10

Microsoft Windows 10, edición de 64 bits

Microsoft Windows Server 2019, edición de 64 bits


Opciones de línea de comandos

El paquete del usuario final puede modificarse agregando parámetros en la línea de comandos. Dichos parámetros se pueden combinar separándolos mediante espacios. En caso de que la línea de comandos contenga un error como, por ejemplo, un carácter no válido o formato incorrecto, se muestra un mensaje de error. Se omitirán los parámetros en la línea de comandos que sean incorrectos. La siguiente descripción de línea de comandos está disponible también (en inglés) ejecutando el paquete del usuario final con la opción “/?”.

Los paquetes de precarga admiten las siguientes opciones de línea de comandos:

/? muestra la información de la línea de comandos (sólo en inglés)

/q desactiva la barra de progreso

/p solicita al usuario que conecte la impresora

/s desactiva los mensajes de error del usuario final

Los paquetes de la impresora de red admiten las siguientes opciones de línea de comandos:

/? muestra la información de la línea de comandos (sólo en inglés)

/q desactiva la barra de progreso

/s desactiva los mensajes de error del usuario final

/ip <idirección IP> utiliza la dirección IP especificada para identificar la impresora, p. ej. /ip 120.25.5.56

/hw <dirección de hardware> utiliza la dirección de hardware especificada para identificar la impresora, p. ej. /hw 0001E6299128

/hn <nombre de host> utiliza el nombre de host especificado para identificar la impresora, p. ej. /hn Nombre_de_mi_host

El nombre de host no puede tener más de 255 caracteres y sólo pueden utilizarse los siguiente:A-Z, a-z, 0-9 y el guión (-).

/pn <nombre del puerto> utiliza el nombre especificado como nombre del puerto, p. ej. /pn HPPort

El nombre del puerto no puede tener espacios ni ocupar más de 128 caracteres.

/n ”<nombre de la impresora>” utiliza el nombre especificado como el nombre de la impresora, p. ej. /n "HP LaserJet 8150"

El nombre de la impresora debe aparecer entre comillas, no puede tener más de 40 caracteres y no puede tener ninguno de los siguientes caracteres especiales: ! # ,

/d establecer esta impresora como predeterminada

/sn ”<nombre de recurso compartido>” activa la impresora compartida y utiliza el nombre especificado para la impresora, p. ej. /sn ”Mi impresora compartida HP LaserJet 8150”

El nombre del recurso compartido debe aparecer entre comillas, no puede ocupar más de 80 caracteres y no puede tener ninguno de los siguientes caracteres especiales: / \ : ; “ ? * + = < > [ ]

© Copyright 2019 HP Development Company, L.P.